0

I have just installed ubuntu 16.04 on my machine. I am able to connect via ethernet cable, but no wifi networks appear.

I searched and found this post about the same wireless card (details below): Can't find wifi on newly installed Ubuntu 14.04 which does not work. The last step of the solution says to use the following commands:

sudo apt-get update
sudo apt-get install bcmwl-kernel-source

When I do, the console says that the driver is already the latest version. I have tried following instructions as in this YouTube video with no results; Software and Upgrades > Additional Drivers states that my driver is in fact being used, but I still get the 'empty segment' for wifi networks. Nothing is shown despite the house being exposed to at least a dozen networks. Is there some other setup step I am missing?

lspci -vq | grep -i net
08:00.0 Network controller: Broadcom Corporation BCM4314 802.11b/g/n (rev 01)
09:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd, RTL8101/2/6E PCI ex

It's a bit of a cluster because when Ubuntu installer executed, it nuked my entire harddrive including windows recovery partition, so I'm stuck with Ubuntu as very much a beginner and no wifi, and very inconvenient corded internet. If anyone has a solution, please speak up.

  • Please edit your question and add output of lspci -knn | grep Net -A3; rfkill list terminal command. – Pilot6 Jun 28 '17 at 18:25
  • I noticed that the person who asked the question you linked to has BCM43142, but you have BCM4314 (not the same after all) so there's no reason to expect that solution to work for you – Zanna Jun 28 '17 at 18:30
  • the solution tried is inherently correct in that you need to install the broadcom drivers. it failed because the solution you viewed is for a different card. search drivers for your card. – ravery Jun 28 '17 at 18:40
  • FWIW it's very unlikely that Ubu nuked your harddrive as the defaults are to install alongside a windows partition when it's detected; you can select to override that, but you have to select it. What may have happened is that the Windows partition is still there and just needs adding to the list in grub so that you can select it when you boot up. sudo fdisk -l from a console will list all partitions. – pbhj Jun 28 '17 at 23:59