1

I recently bought an Acer Swift 3. The installation of Ubuntu 16.04.02 LTS was a success, however after the installation is finished when I want to boot into Ubuntu it gets stuck at the purple screen. I searched the web for a solution and find out that it was related to ACPI. However only parameter that is enabling me to get past that boot screen is acpi=off and when I boot using that string I can't use my mouse. The cursor is missing and it feels like the touchpad is completely useless at that time. Any ideas how to get past around this issue, should I contact with Acer? Any help will be appreaciated. Thanks already.

1
  • I have Acer Travelmate x349 which is similar. I took Ubuntu Gnome 14.04.5. This seems to work stable. Newer versions did not work for me. (Mint, Debian, Ubuntu, Sparky) Use UEFI with secure Boot turned off. Add the Boot Loader to trust Store of the Bios.
    – Denis
    Aug 27 '17 at 13:21
0

I have the same laptop, and i had the same problem the first launch. Near the acpi=off kernel option you need to add these options :

i8042.reset i8042.nomux i8042.nopnp i8042.noloop

Once your computer booted up, your trackpad will be supposed to work, and you will need to add these option to the grub file. Open a terminal and type :

sudo gedit /etc/default/grub

Find the line "GRUB_CMDLINE_LINUX_DEFAULT" and add i8042.reset i8042.nomux i8042.nopnp i8042.noloop between the quotes. Save and exit gedit. Go back to your terminal and type :

sudo update-grub

(Ignore update-grub2)

Now, the trackpad boot options will be executed automatically.

If you contact Acer, they will answer you : "You are not supposed to run Ubuntu on this Laptop". And because you did it, you don't have your warranty anymore :/

And because of the acpi=off option, you need to know that your laptop will not be 100% stable. On mine, as an example, i dont have any information about the battery status ... Your wifi may not work as well, but you only have to reboot the computer, as many times as you need, to fix this issue (once, it needed 5 reboots ...). Of course, i didnt find any fix for those issues

I hope i was helpful, Cordialy

PS : sorry for the English, i'm French :)

2
  • Thanks a lot. I'll try your solutions when I have the time. Funny thing is when I updated the kernel the problem solved, I didn't had to set acpi to off. But only one kernel worked and the other updates doesn't have the same effect. I'm trying to remember specifically which version worked around the problem and I'll report a bug to ubuntu, and talk to acer. I know they would say that but maybe they would update their uefi in the future, fixing this problem. Jun 30 '17 at 13:51
  • Okay I'm not sure if I should add this to my question or add it as an answer or comment but you should know that after installing elementary OS and kernel 4.10.1 it looks like the problem is solved. I can boot into OS without setting acpi to off and my laptop hadn't still crashed so... I should probably try installing that kernel with ubuntu too but I've had enough of my computer so I'll do that later. So maybe you could give it a try too and let us know also should I notify this to the developers? @NicoTine Jun 30 '17 at 15:29
0

Nicotine, your answer simply will not work. The reason this whole problem is occurring is because of a problem between Acer Firmware and Linux Kernels 4.11 and below. I am copy pasting my Ubuntu 16.10 Acer Swift-3 multiple problems

Or I will just copy pasta it here.

The answer is simple, but first a little bit of backstory.

I too, own one of these machines, and I was famished when I found that Ubuntu would hang and would boot 1/10 percent of the time.

The reason is the following. The Acer Swift 3 firmware and the ACPI firmware in Linux 4.11 & below have a bit of a conflict...

But the solution is this! Linux kernel Devs fixed it in Kernel 4.12 and above! Ubuntu 17.10 officially comes with the latest kernel, but it will release after a few months.

so a TEMPORARY solution (not recommended by me, see below why) is to boot an Ubuntu ISO with the Mainline / unstable 4.12 or above kernel, or boot Ubuntu with acpi=off, use a separate mouse and keyboard, install the Mainline Kernels, and remove that acpi=off from the grub boot commands.

Why is this not a good solution? because Mainline kernels have many bugs and stuff, and I got harsh karma from using Mainline kernels. my new Acer Swift 3's battery total went from 100% to 98%!!! I can never charge my laptop to its full potential now! And that is to be expected in any laptop, but the reason why this is such a big problem is because the battery went down in 1 day!! within a day, the total of my new laptop took a hit.

that is why I will use Linux on MY Acer Swift 3 only once Ubuntu 18.04 releases (for stability, but 17.10 will also work) But you are free to go ahead and use risky software and kernels.

LINK for Ubuntu ISO with mainline kernel -> http://linuxiumcomau.blogspot.com/2017/06/interim-ubuntu-1704-iso-with-mainline_29.html

TIP - Install That ISO, and upgrade its Mainline kernel to the latest, or at least to 4.12, because it comes with 4.12RC7.

Or maybe try an "unstable" Ubuntu kernel, but be warned, battery life takes a hit when using these kernels, so remember to use TLP ;) Good Luck!

0

Thank you for your instructions. It helped me get my dual boot Windows 7 / Ubuntu 16.04.02 working on my Acer Travelmate X349. I have BIOS version 1.10 (had to update the BIOS twice since I bought the computer in March), reinstall Ubuntu specifying the boot loader on the partition where my Ubuntu was installed and not on the HDD like on my previous computer with dual boot.

We had to use Boot Repair and specify the trusted path HDD0 EFI and choose Ubuntu and one of the choices in GRUB. So, when the computer starts, I need to hit F12 at the very beginning and choose the GRUB path I have specified manually in the BIOS so that the grub screens appears. And I don't have the purple screen anymore.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.