10

When I start my Unity desktop the CPU indicator shows only one bar and it is set to Powersave. When I switch to Performance I have to enter an admin users password.

But after system restart my CPU is back in Powersave. How to set Performance as the default, so I don't have to switch it after every restart?

20
+25

Performance and Powersave Governor Policies

There are various options for setting CPU governor policy described in Ask Ubuntu and other websites:

Keep in mind most websites suggest leaving CPU governing at Powersave. I'm on a laptop and found using Intel's ThermalD and P-State technologies coupled with TLP power management has best result for frequencies, fan speed and temperature.

Summarizing above links

To summarize achieving your goal from the above answers use:

Install cpufrequtils:

sudo apt-get install cpufrequtils

Then edit the following file (if it doesn't exist, create it):

sudo nano /etc/default/cpufrequtils

And add the following line to it:

GOVERNOR="performance"

Save and exit.

For changes take effect, run:

sudo /etc/init.d/cpufrequtils restart

Then you can run cpufreq-info to see informations about your cpu frequency, governor and more:

$ cpufreq-info
    current policy: frequency should be within 800 MHz and 3.90 GHz.
              The governor "performance" may decide which speed to use
              within this range.

As per this Q&A: How to set "Performance" instead of "Powersave" as default?

If you want performance governor all the time you need to edit /etc/rc.local and insert these lines before the last line containing exit 0:

sleep 120 # Give CPU startup routines time to settle.
cpupower frequency-set --governor performance
  • 2
    This is also applicable to Ubuntu 18.04 and 18.10 just in case anyone is wondering... – der_michael Dec 11 '18 at 5:57
4

I cannot comment because I have low reputation but I want to add the accepted answer. You will also need to run

sudo /etc/init.d/cpufrequtils restart

for this to take effect on your system. You should then see your frequencies hovering around the max listed and

current policy: frequency should be within 800 MHz and 3.90 GHz.
              The governor "performance" may decide which speed to use
              within this range.

When you type cpufreq-info

  • 2
    Thanks for that. I've submitted a edit to the accepted answer with your suggestion; – Elias Soares Feb 3 '18 at 20:22
  • You can authorization to other sites, like stackoverflow to gain 100 reputation for you. – Bejond May 31 '18 at 1:33
1

I'm on Xubuntu 18.04.02 LTS and installing cpufrequtils by sudo apt-get install cpufrequtils, made it possible to reduce the max CPU-speed. A nice option to have as the fan has stopped working.

After looking at the info by cpufreq-info, I created a file by sudo nano /etc/default/cpufrequtils, and wrote into it as in picture below. I found out it was of use to also set a value for min speed.

enter image description here

Lastly the command to make the change take action sudo /etc/init.d/cpufrequtils restart, resulting in this output from cpufreq-info:

enter image description here

To be clear - this is off course not my own findings, only a result of conclusions made from other earlier questions, comments, and answers on this forum. Especially the answer in this very question from WinEunuuchs2Unix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.