2

I have a laptop Dell Precision 3510 and my Kubuntu 17.04 very often gets frozen on startup.

What I have seen from the output of the command journalctl -xb is, it gets frozen due to timing out on disks.

The first error that I can see there is this:

systemd[1]: dev-sda1.device: Job dev-sda1.device/start timed out.

I tried to play with /etc/fstab and replaced UUID with /dev/sdXX links but this did not help.

This is output I get:

čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: dev-sda1.device: Job dev-sda1.device/start timed out.čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: Timed out waiting for device dev-sda1.device.
-- Subject: Unit dev-sda1.device has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- Unit dev-sda1.device has failed.
-- 
-- The result is timeout.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: Dependency failed for File System Check on /dev/sda1.
-- Subject: Unit systemd-fsck@dev-sda1.service has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- Unit systemd-fsck@dev-sda1.service has failed.
-- 
-- The result is dependency.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: Dependency failed for /boot/efi.
-- Subject: Unit boot-efi.mount has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- Unit boot-efi.mount has failed.
-- 
-- The result is dependency.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: Dependency failed for Local File Systems.
-- Subject: Unit local-fs.target has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- Unit local-fs.target has failed.
-- 
-- The result is dependency.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: local-fs.target: Job local-fs.target/start failed with result 'dependency'.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: local-fs.target: Triggering OnFailure= dependencies.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: boot-efi.mount: Job boot-efi.mount/start failed with result 'dependency'.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: systemd-fsck@dev-sda1.service: Job systemd-fsck@dev-sda1.service/start failed with result 'dependency'.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: dev-sda1.device: Job dev-sda1.device/start failed with result 'timeout'.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: dev-sda3.device: Job dev-sda3.device/start timed out.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: Timed out waiting for device dev-sda3.device.
-- Subject: Unit dev-sda3.device has failed
-- Defined-By: systemd
-- Support: http://www.ubuntu.com/support
-- 
-- Unit dev-sda3.device has failed.
-- 
-- The result is timeout.
čen 27 07:47:51 NEHEZ-Precision-3510 systemd[1]: Dependency failed for /dev/sda3.

Any idea how to fix it?

Here is my /etc/fstab file:

# /etc/fstab: static file system information.
## Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system>                                 <mount point>   <type>   <options>               <dump>  <pass>
# / was on /dev/sda2 during installation
# UUID=2f75b38f-6fa8-473a-b893-e03514a17b1f
/dev/sda2                                       /               ext4    errors=remount-ro       0       1
# /boot/efi was on /dev/sda1 during installation
# UUID=D926-7D91
/dev/sda1                                       /boot/efi       vfat    umask=0077              0       2
# swap was on /dev/sda3 during installation
/dev/sda3                                       none            swap    sw                      0       0

UPDATE #1 on 29 June 2017 7:11 CEST

I need to mention that this issue does not always occur; but, I would say in 50% of cases the system is started.


UPDATE #2 on 7 July 2017 8:45 CEST

The suggested answer below obviously did not fix the problem.
This morning I restarted my system and it got frozen again.

My /etc/fstab file now contains the following entries:

UUID=D926-7D91                              /boot/efi   vfat    defaults                0   1
UUID=2f75b38f-6fa8-473a-b893-e03514a17b1f   /           ext4    errors=remount-ro       0   1
UUID=de138edb-ee13-4c44-9cbd-cc777e56cca7   none        swap    sw                      0   0

Does anybody have an idea what this issue could be?


UPDATE #3 on 11 July 2017 10:40 CEST

Here is a screenshot of the partitions from GParted:

here.


UPDATE #4 on 19 July 2017 11:22 CEST

This issue still persists even if I am using kernel 4.12.2.


UPDATE #5 on 15 August 2017 15:07 CEST

I do not know if the following fact has fixed my issue but since the time I am using kernel 4.12.4 (neither 4.12.7 nor Ubuntu's stock one 4.10.0-32) I have not faced the issue anymore.

The other fact that could help (but I do not believe in it much) was that I disabled Kubuntu's boot splash.

I am not able to use a kernel newer than 4.12.4 because then I am facing another issue with VirtualBox 5.1.26 - Windows 10 guest just got stuck and I have to kill V-B process.

7
  • Try adding nofail to the mount options for /dev/sda1.
    – muru
    Jun 28, 2017 at 5:38
  • Does your laptop have a ssd or a hdd? The reviews make quite a point that this model gets very hot very quickly. If you have a ssd heat is not as big a problem as it would be for a hdd. Especially wearing it out over time. laptopmag.com/reviews/laptops/dell-precision-3510 You might think about looking at the SMART info on the drive. Also running trim.
    – jones0610
    Jun 28, 2017 at 5:39
  • I do have SSD Samsung 850 EVO 500GB but my laptop does get hot only when it is heavily busy, normally it is cold. I am satisfied with this Dell but this problem makes me crazy. This issue happens quite often even when starting the laptop after long time being off so I am 100% sure it is not related to the laptop itself.
    – Petr Nehez
    Jun 28, 2017 at 10:17
  • I will try to add nofail for /dev/sda1 as @muru suggested, it's really weird.
    – Petr Nehez
    Jun 28, 2017 at 10:22
  • Have you checked the firmware in your Samsung SSD? Download the Samsung Magician in Windows and check it asap. You might also check to make sure that your BIOS is up to date. Ping me at @heynnema. Report back.
    – heynnema
    Jun 28, 2017 at 16:06

3 Answers 3

2

Edit /etc/fstab back to using UUID's instead of /dev/sdaX.

To fix your problem, specifically change the following line...

Change this:

# /boot/efi was on /dev/sda1 during installation
UUID=D926-7D91    /boot/efi      vfat    umask=0077     0       2

To this:

# /boot/efi was on /dev/sda1 during installation
UUID=D926-7D91    /boot/efi      vfat    defaults       0       1
                                             ^                  ^
                               change here___|__________________|

Update #1:

To check the file system on your Ubuntu partition...

  • boot to the GRUB menu
  • choose Advanced Options
  • choose Recovery mode
  • choose Root access
  • at the # prompt, type sudo fsck -f /
  • repeat the fsck command if there were errors
  • type reboot
14
  • I am already using UUIDs only without any affect and am gonna change my /etc/fstab as you suggested.
    – Petr Nehez
    Jun 29, 2017 at 5:17
  • Hmm, I am starting to be happy :), this change seems to work. I will perform few more restarts and will let you know the result and then accept your answer. Thanks for now @heynnema
    – Petr Nehez
    Jun 29, 2017 at 5:30
  • What do you think @heynnema - which piece of fstab was causing the issue? <options> with umask=0077 or <pass> with the value 2?
    – Petr Nehez
    Jun 29, 2017 at 5:36
  • Voilà, this has fixed my problem. I have restarted & shut down my system few times and so far there was time out. Thank you @heynnema !
    – Petr Nehez
    Jun 29, 2017 at 6:45
  • The umask=0077. Glad it solved the problem. Remember to check your SSD firmware. Please also vote on my answer by clicking the grey up arrow just to the left of my answer. Thanks!
    – heynnema
    Jun 29, 2017 at 13:48
1

I had similar problems with dell laptop too. E.g. I\O hangs, lags, file system was messed up so I had to use fsck from liveusb. What helped me was using iommu=soft at a boot time.

Here line from my grub config

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash iommu=soft" Once you update config run sudo update-grub. It just works for me.

5
  • I don't think this is my case while I have no issues with I/O or with file system - the problem I am having is that during startup process components are not initialized in the correct order. When startup process times out I get a message and can continue as a root in the text mode only - from terminal in this situation I could get the log posted on top.
    – Petr Nehez
    Jun 28, 2017 at 11:12
  • iommu responsible for memory allocation for all devices(disks,usb,sound,controllers etc). It might be the case. I also suggest to do fsck from liveusb because of "Subject: Unit systemd-fsck@dev-sda1.service has failed"
    – Aleksey
    Jun 28, 2017 at 11:16
  • OK @Aleksey, I will try this option.
    – Petr Nehez
    Jun 28, 2017 at 11:20
  • Adding the option iommu=soft did not help @Aleksey, I am still in the same troubles...
    – Petr Nehez
    Jun 29, 2017 at 4:45
  • And the disk is fine, fsck is not needed, a message systemd-fsck@dev-sda1.service has failed is because the partition was not mounted.
    – Petr Nehez
    Jun 29, 2017 at 4:48
0

you have to use uuid for mounting, assuming you have the right ids.

make the line read UUID=D926-7D91 /boot/efi vfat umask=0077 0 2

do a similar change for the other partition mounts

the folder /dev does not exist until / (root partition) has been mounted.

1
  • As I already mentioned in the initial post, I was playing with /etc/fstab and the issue occurred even when I had UUIDs there for all partitions...
    – Petr Nehez
    Jun 28, 2017 at 10:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.