Update: I previously posted this question but only one person responded (thank you, @ubashu!) suggesting that I update to 17.04 (from 16.10).

I did, and the printer still didn't print.

I removed the printer from within Printers (system-config-printer) and searched for it again. The program responded better than it had in 16.10, and I was hopeful, but it still didn't print.

I tried editing that previous post with the update, and replied with a comment tagging @ubashu, but I also got no response there.

Apologies if this isn't in line with the site rules, but since no one responded to my edit/update, I'm posting this as a new question. Is this printer simply not ever going to "work with Linux" for some reason?

Thanks for your attention.

Original message

I appreciate any suggestions you can give me. I'm replacing a Windows XP laptop from 2008 with a new Ubuntu machine.

I'm having trouble printing from a Samsung ML-2165W. (The printer does work normally from both a Windows XP machine [which is being replaced I seem to have successfully installed the printer. I'm using the official Samsung Printer Driver for Linux, V1.00.36_00.91.

I was initially running Ubuntu 16.10, release 16.10, codename yakkety.

UPDATE: As suggested, I upgraded to Ubuntu 17.04. Upon reboot I went to system-config-printer, removed the printer, added it again, and tried to print a CUPS test page. The print job appears on the print queue and the printer's green "connection" light starts blinking, but it does not print.

After approximately 10 minutes, the printer itself printed a page reading:

SPL ERROR - Incomplete Session by time out
POSITION : 0X94B (2379)
SYSTEM: h6fw_5.57/os_hook
LINE: 1425
VERSION: SPL 5.57 01-12-2012

(end of update)

The printer does have WiFi capabilities, but I'm connected to it using the standard USB cable. I've added the printer in the "Printers" program. It identifies it as a "Samsung-ML-2160 Series. When I go into Properties and Print Test Page, the job gets added to the Print Queue as Processing, but the printer does not respond.

The green LED blinks, but the printer doesn't print anything. If I press the "Power/Continue" button on the printer, occasionally it spits out a page reading:

SPL ERROR - Incomplete Session by time out
POSITION : 0X1b9 (441)
SYSTEM: h6fw_5.57/os_hook
LINE: 1425
VERSION: SPL 5.57 01-12-2012

(I think this is the printer itself, and not the OS.)

I've tried removing everything and re-downloading (as per this and other tutorials), but to no avail.

I've also installed and successfully printed from the printer (even using WiFi) on a Windows XP machine as well as a Samsung smartphone, so I know the printer is working properly.

1 Answer 1


Sorry you didn't get much of a response on your first attempt to solve your problem. That happens sometimes.

This is just my opinion but I would expect to have better driver support on the stable, hardened Ubuntu 16.04 LTS platform versus something else. I had similar issues trying to get HP wireless printers to work in my Ubuntu environment and resolving those issues took a lot of Internet research. A good place for you to start is http://downloadlinux.net/2016/03/01/how-to-get-install-samsung-ml-2165w-printer-scanner-drivers-for-ubuntu-16-04-xenial-lts-linux/

Samsung makes a point that it does provide some support for Linux but that the level of support and functionality is going to vary from product to product. Which is another way of saying that Linux users are mostly on their own. http://www.samsung.com/us/support/answer/ANS00045346/

I didn't thoroughly research how to get these printers to work since I have no Samsung printers in house to use for testing. But in my HP environment I quickly found out that trying to use CUPS was a dead end. You should be able to print directly via the USB as a connected printer. For wireless printing you'll need to configure the printer to acquire a DHCP IP address and a few other settings. These operations would probably be easier done from a Microsoft machine although in my case, HP provided a Ubuntu tool that worked well.

Once your Samsung printer is properly configured to print in a wireless environment (you may already have that piece working) it's just a matter of adding the printer via system settings->Printers->Add->Network Printer

If this approach fails, I'd try to set things up using a Samba connection which is more complicated but should work ok.

The green light blinking indicates that you at least have some sort of a connection to the printer but that an uncorrupted file transfer is not working. This could be a CUPS issue which is what I experienced and decided to go another route.

You didn't mention installing the Samsung unified linux driver and configurator. http://downloadcenter.samsung.com/content/UM/201205/20120518170921365/EN/english.pdf page 171. You're probably not going to get very far unless you do this.

It's unlikely that your printer "will never work on Linux". However, the degree to which products work depends greatly on how much effort and cooperation Vendors are willing to invest in supporting their Linux customers.

  • You're very welcome and I hope it helps. Happy to chat with you on IRC if you get stuck getting this resolved.
    – jones0610
    Jun 28, 2017 at 1:21
  • I do have it working on the network, printing from both Windows and Android. When I open the About window for system settings->Printers->Add->Network Printer it says "system-config-printer, a CUPS configuration tool". Anyway, when I open it I get weird "screen tearing" just on that window. See pasteboard.co/2pg0spF7x.png I have Samsung's univ. linux driver but had never heard of a configurator. I'll try to install it. I'm only at this computer once a week, on Tuesdays. @jones0610 could I possibly trouble you next Tuesday with my status update?
    – maleta
    Jun 28, 2017 at 1:22
  • If your wifi printer is broadcasting on the same LAN that your Ubuntu machine is connected to, it should be discovered and displayed right below "network printer". Since it's not listed, that says that the printer is not broadcasting or the Ubuntu machine isn't seeing the broadcasts. As I said, the linux driver and configurator install is a requirement so it's silly to speculate further until that has been done.
    – jones0610
    Jun 28, 2017 at 1:29
  • Hi again @jones0610 I'm having trouble following Samsung's instructions to install the unified linux driver. Could you help me out? On p.85 of that PDF you linked, they seem to say to log in as root. Is that correct? Should I temporarily enable logging in as root in order to install this?
    – maleta
    Jul 10, 2017 at 21:22
  • You could do that but in Ubuntu and similar distros that discourage root logins, preface the commands in the procedure that need root access with sudo.
    – jones0610
    Jul 11, 2017 at 0:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .