3

I have recently installed Ubuntu on a Lenovo Y520. I'm not able to turn on the wifi.

I heard that there are some issues with WiFi in Ubuntu 17.04 but they all are related to connectivity.

I wonder if it could be related to BIOS settings as I had to change a few to install Ubuntu on this machine.

I didn't find any key on the keyboard or any button on the laptop to enable/disable wifi physically.

Wifi is working fine in Windows OS on the same machine. So I don't think it is switched off.

03:00.0 Network controller [0280]: Intel Corporation Wireless 8265 / 8275 [8086:24fd] (rev 78)
Subsystem: Intel Corporation Device [8086:1010]
Kernel driver in use: iwlwifi
Kernel modules: iwlwifi

$ rfkill list all
0: ideapad_wlan: Wireless LAN
    Soft blocked: no
    Hard blocked: yes
1: ideapad_bluetooth: Bluetooth
    Soft blocked: yes
    Hard blocked: yes
3: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
4: hci0: Bluetooth
    Soft blocked: yes
    Hard blocked: no

There is no change after rfkill unblock all

2
  • Please edit your question to add the result of the terminal command: rfkill list all Also, isn't Fn+F7 the combination to turn on airplane mode which turns off the wireless radio? – chili555 Jun 27 '17 at 23:09
  • Thanks. Yes. I had already turned airplane mode off. I have also copied intel driver to "/lib/firmware". But it didn't work. I'll update the question with rfkill cmd op. – Amit Kumar Gupta Jun 27 '17 at 23:53
9

Run in a terminal

sudo tee /etc/modprobe.d/ideapad.conf <<< "blacklist ideapad_laptop"

and reboot.

0
-3

First try rfkill unblock all. if this doesn't fix your problem try the following. open the file /etc/network/interfaces as sudo nano /etc/network/interfaces and append the following lines to /etc/network/interfaces.

auto "your wireless interface's name" iface "your wireless interfaces's name" inet auto

here replace "your wireless interface's name" by the name of your wireless network interface as you see it in ifconfig -a". After doing this you have to make the service network-manager manages the interfaces listed in /etc/network/interfaces, because network-manager doesn't manage the interfaces listed in the /etc/network/interfaces file out of the box i.e. by default.

To turn on interface management, open the network-manager config file i.e. sudo nano /etc/NetworkManager/NetworkManager.conf. and change the line

[ifupdown] managed=false

to

[ifupdown] managed=true then restart the network-manager service by:

sudo service network-manager restart

the interface should be managed and up.

If this fails try ifup "your wireless interface's name".

4
  • 1
    It is a very bad idea to change /etc/network/interfaces . It will disable Network manager. The problem is with rfkill and ideapad_laptop. – Pilot6 Jun 28 '17 at 20:32
  • @endrias it dint work. – Amit Kumar Gupta Jun 28 '17 at 20:37
  • @AmitGupta what does the command rfkill list reply? – endrias Jun 28 '17 at 21:37
  • @endrias added in question. It was saying hard block :yes and soft block: no – Amit Kumar Gupta Jun 28 '17 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.