0

I have a separate hard drive where my games and steam files are stored that I use on Windows. When I try to install games to that hard drive using steam I get an error that says “new steam library folder must be on a filesystem mounted with execute permissions”. After searching for solutions, I tried to find a way to change the permissions of the drive and what I know is that you can’t change the permissions on a NTFS filesystem so I edited my fstab file and added "permissions" on the line for my drive and I have tried to edit the permissions by opening a file system as root, right clicking and selecting properties but every time I change it, it just goes back to root. On properties it says the owner is root with read & write access and the group is also root. I have another drive shared by windows where most of my files are stored which I use with both windows and Ubuntu and there are no permission problems with that drive. When I select properties from that drive it says my username with read & write access with the group root.

This is what is says in fstab for my 2 drives. The top one is the windows hard drive that works fine and the bottom one is the drive I’m trying to change the permissions of.

/dev/disk/by-uuid/8482DBD682DBCB36 /mnt/windows auto nosuid,nodev,nofail,x-gvfs-show,remove_hiberfile,uid=1000 0 0

/dev/disk/by-uuid/DC9C1F849C1F587A /mnt/DC9C1F849C1F587A ntfs-3g nosuid,nodev,nofail,x-gvfs-show,permissions,umask=002 0 0

This is the Windows drive with my normal files with the right permissions

And this is the 1tb drive that I install my games on that I can't change the permissions of.

  • check the permissions on the folder that you are mounting to – ravery Jun 27 '17 at 17:52
  • The owner is root and the group is root – user705051 Jul 3 '17 at 12:30
  • is that the same as the other folder? I think you need to have write permission on the folder it mounts to – ravery Jul 3 '17 at 12:37
  • The other folder's owner is my username – user705051 Jul 3 '17 at 12:47
  • make yourself owner of the this folder also – ravery Jul 3 '17 at 12:49
0

A possible cause of read-only NTFS partition could be the Fast Startup turned on in Windows (8 and 10 version).

See this article to learn what it is (basically, a hybernation variation), and how to disable it.

  • I logged into Windows and changed the setting but it still can't change the permissions. – user705051 Jun 29 '17 at 11:00
  • Mine is very simple in fstab: UUID=FC34798E34794CA0 /home/thunder/DiskD ntfs-3g permissions 0 1 – Aurel Branzeanu Jun 30 '17 at 1:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.