0

We use many variants of Indian Keyboards - Devanagari Inscript (Default Indian), Hindi WX, Malayalam Inscript etc. In earlier Ubuntu versions, we could easily add these keyboards through the System Settings GUI dialogues. In recent 16.04 and 17.04, we could see default Indian (and Urdu) only. How to add other variants?

Do any package need to be installed? We searched the package repository but could not find any separate package describing these variants.

We suppose it needs additional configuration. It might be silly, but don't know how to.

We use multiple distros - Ubuntu 16.04.2, 17.04, Arch Xfce, Fedora 25 Xfce etc. and we could not solve in all those distros. If we could make it in one distro, it must be similar in others.

  • 1
    see Unicode keyboard layout missing on Tamil and No Bengali keyboard layout in Ubuntu 17.04? and this commit - I wrote this because I think it may have been a bad decision at least for some languages. You can get lots of input methods by installing ibus-m17n - apparently the layouts are integrated in Unity when you install this package, but I can't test as I don't use Unity – Zanna Jun 27 '17 at 8:53
  • Thanks @Zanna for the comment indicating forums on similar language layouts moved to extras in newer xkb-data. I don't have a Unity system right now with me to test. But, it must work. Any idea how to do it in Arch and Fedora XFCE? (I am aware that it's Ubuntu Forum, still) – Gaudha Jun 27 '17 at 9:53
  • I have no idea! I use Ubuntu MATE and I can find a limited number of xkb layouts (for example I find a useable one for Tamil) in keyboard layouts. If I install ibus-m17n and set IBus as input method, start the ibus-daemon, select an input method from the ibus-setup menu and reboot, I can access many input methods for Indian languages in the IBus preferences, it's just not integrated in the keyboard settings like in Unity. (PS Unity is the default DE of Ubuntu - if you have a vanilla Ubuntu 16.04, it should work) – Zanna Jun 27 '17 at 10:00
  • @Gaudha: I think it depends on the desktop tools for managing keyboard layouts. In the Ubuntu 'family', Kubuntu (with KDE) shows also the extras by default, but that's the only case I'm aware of which does that. Can't tell if there is an easy way to fix it in Xfce. – Gunnar Hjalmarsson Jun 27 '17 at 11:39
  • See also this bug report - the layouts will be brought back soon – Zanna Jun 27 '17 at 18:15
0

Try executing the following on command line

gsettings set org.gnome.desktop.input-sources show-all-sources true

(Reboot the machine if you don't see more keyboard layouts right away.)

Not the answer you're looking for? Browse other questions tagged or ask your own question.