0

I have the following ifconfig:-

enp0s31f6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 10.21.0.11  netmask 255.255.240.0  broadcast 10.21.15.255
        inet6 rr50::9r16:r57r:rrr6:rr86  prefixlen 64  scopeid 0x20<link>
        ether 88:88:rr:8r:b8:88  txqueuelen 1000  (Ethernet)
        RX packets 1283617  bytes 447482292 (447.4 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 777459  bytes 128121082 (128.1 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 16  memory 0xf7100000-f7120000  

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 62037  bytes 26306447 (26.3 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 62037  bytes 26306447 (26.3 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Also my /etc/network/interfaces looks like this:-

# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

To assign a static IP i tried to add something like this from here:-

auto enp0s31f6
iface enp0s31f6 inet static
   address 10.253.0.50
   netmask 255.255.255.0
   network 10.253.0.0
   gateway 10.253.0.1
   dns-nameservers 8.8.8.8

I save it with sudo and then on terminal type and enter: sudo ifdown enp0s31f6 && sudo ifup enp0s31f6. This does not work. The goal was to enable nomachine access to this server machine from an outside client network. Doing this step led to loss of connection with the server immediately. The above ifconfig results is greek to me and i copied pasted from above SO answer. How to make this work? What are the correct values i should have given for the fields address, netmask, network, gateway.

  • Your values are ok but still don't match your ifconfig.. did you try sudo service networking reload ? Of you are connected over ssh or something it's clear that you lose the connection if the IP changes or the network is not coming up correctly.. – derHugo Jun 27 '17 at 5:40
  • And of course you add YOUR values for the IP and so on assuming your gateway is 10.21.0.1 than address 10.21.0.11 netmask 255.255.240.0 gateway 10.21.0.1 dns-nameservers 8.8.8.8 (don't have to set network if you have set the others) – derHugo Jun 27 '17 at 5:48
  • @derHugo If the broadcast address via DHCP is 10.21.15.255, then I suspect that the gateway may be 10.21.15.1, but user_1_1_1 needs to verify: route -n. Furthermore, I suggest a static address outside the DHCP pool which 10.21.0.11 is not. – chili555 Jun 27 '17 at 12:30
  • No @chili555 I don't think so since his/her ip is 10.21.0.11 and netmask is 255.255.240.0 => IPs available are 10.21.0.1 - 10.21.15.254 ;) Anyway it's just an example – derHugo Jun 27 '17 at 15:11
  • Furthermore we don't know the DHCP pool actually since it may always be smaller than the network eg. 10.21.2.10-10.21.12.255; than the rest could be used by static IPs. – derHugo Jun 27 '17 at 16:56
0

17 doesnt use ifup/down anymore.. it uses netplan.. see the answer from this guy..

Ubuntu 17.10 will not accept static IP

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.