enter image description here

This is what I've got. I cannot boot and I see the two of three little lights on the keyboard blinking all the time and the cooling is working on full power, almost.

I saw in other askubuntu topic suggestion for memory test. I did it. I didn't have any errors.

I am 99,9% sure it is not a hardware problem, because I have Windows 7 and I can boot it and it works just fine.

This problem came without any warning or something. I just turned off the laptop one day and at the other day I couldn't boot.

From recovery mode I get this:


  • At the GRUB screen select the entry you wish to boot in to (most likely the one that's selected as default), press e and then remove 'quiet' and 'splash' from the kernel line if present. You can then press Ctrl-X to boot. This might display a little more information that could be useful. Edit: tumbleweed's suggestion is better, try rescue mode – benwh Jan 5 '12 at 7:56
  • It doesn't boot in rescue mode. It is stuck at the same error. I'm wondering how to copy/paste all the information from the rescue screen. – Ivan Dokov Jan 5 '12 at 8:16
  • 1
    Could you grab /var/log/kern.log from your Ubuntu partition using a Live CD? – Lekensteyn Jan 5 '12 at 10:05
  • I've same issue while I dist upgrade from 14.04, I'm even not able to boot with old kernel and rescue more, how did you solve it. ???? – Nullpointer Oct 27 '16 at 15:07

There you go /sbin/init: No such file or directory. Looks like it can't find a /sbin/init on /dev/sda6.

Maybe have a look from a Live CD, and see what is on sda6? Is it the right partition? Is just that file missing?

You can probably fix it from a Live CD, but I'm not sure what caused it, so I can't give instructions. Reinstalling is probably easier, if you don't know how to fix it, yourself.

  • On sda6 I have the Ubuntu OS. It is the right partition. I've booted from a LiveCD and I see the /sbin/init file in /dev/sda6. I actually don't know how to fix the /sbin/init, but I don't want to reinstall the OS for sure. Help me out fixing the init. PS: Before I post the topic here I did partition check with Gparted from Live CD. It didn't helped. – Ivan Dokov Jan 5 '12 at 9:16
  • It seems I will reinstall the OS after all. – Ivan Dokov Jan 5 '12 at 10:01
  • 2
    I hate to have to suggest that, I'm sure it's fixable, but hard to say how, without sitting down and playnig with the machine... – tumbleweed Jan 5 '12 at 10:04
  • I have the same problem after upgrading to Ubuntu 15.10 . But i cannot even reinstall from the USB bootable ubuntu 14.04. There is a black screen with grub command prompt – curious Dec 8 '15 at 4:07
  • I've same issue while I dist upgrade from 14.04, I'm even not able to boot with old kernel and rescue more, how did you solve it. ???? – Nullpointer Oct 27 '16 at 15:07

I had a lot of trouble with that same exact problem and it took me a while but i managed to fix my problem with the following solution. I installed Boot repair and repaired my file system. I have LVM(logical volume mangement) and i couldnt run fsck. you can follow how to install it from https://help.ubuntu.com/community/Boot-Repair or

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sed 's/trusty/saucy/g' -i /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list
sudo apt-get update
sudo apt-get install -y boot-repair && (boot-repair &)

after that, boot-repair should open automatically

  1. click the "advanced options" to expand
  2. in the "Main options" tab, check "Reinstall GRUB" and "Repair file systems" Repairing file systems is the most important part as the kernel panics happen because of some file system error.
  3. int the "Grub options" tab, check "Purge GRUB before reinstalling it"
  4. and of course you must have internet connection as you will be installing new files. and finally click Apply.

Just to add my 2c for those encountering this problem when running virtual machines. I was seeing the same message when trying to use VM migrated from VirtualBox to VMWare ESXi. None of the solutions above have worked to resolve the issue, the only option that resolved the issue was to manually convert the disk image into VMWare format:

 /Applications/VMware\ Fusion.app/Contents/Library/vmware-vdiskmanager -r ubuntu-disk1.vmdk -t 4 ../ubuntu-disk.vmdk

The important part being the -t 4, which creates ESXi-ready disk image. I've used VMWare Fusion as an example but any distribution of the vmware-vdiskmanager can be used.


From my experience, I think that this problem is caused by upgrading to a newer kernel version.

Force shutdown and then power on again. Select the Advance option for Ubuntu or Elementary. In the next tab, just choose a previous kernel version and hit Enter and it will go to desktop normally.


I got this issue with ubuntu 18.04, on upgrading my distro from 16.04 to 18.04, The boot process throws, Kernel Panic

sbin/init: No Such file or Directory
Kernel Panic - Not Syncing : Attempted to kill init !

In order to resolve this, I booted from Live Ubuntu 18.04 disk, then i replaced the contents of my filesystem directories

/bin & /sbin

with the corresponding content of the directories /bin & /sbin of stock filesystem of Live Ubuntu disk.

First find the disk partition which has the probelm in my case it was /dev/sda5 now boot from the live disk and mount /dev/sd5 with the Live Disk

open terminal and run the following commands to replace the contents

cp -r -i /bin /media/ubuntu/<name of your partition folder>
cp -r -i /sbin /media/ubuntu/<name of your partition folder>


cp -r -i /bin  /media/ubuntu/cdfb882d-e33c-49b5-8965-fea541464686/bin/
cp -r -i /sbin /media/ubuntu/cdfb882d-e33c-49b5-8965-fea541464686/sbin/

shutdown the pc and reboot.

Done Hope this may help!

  • Your wording is a little confusing. I think you're saying that you mounted your root partition in order to replace your filesystem's /bin and /sbin folders with the "stock" /bin and /sbin folders from your Live CD , which does make sense, but maybe just edit so it's a bit clearer? Basically just don't refer to /bin and /sbin without saying explicitly whether you're talking about the problem directories in your root partition, or the "stock" ones from the Live CD, because the directories themselves have the same names. – Hee Jin May 8 '18 at 16:29
  • @Emily I edited the post, i hope its not confusing now.. – Shahbaz Ali May 10 '18 at 4:57
  • Awesome, I think that's much clearer than before :) – Hee Jin May 10 '18 at 20:20
  • 1
    This is bad because the package manager will now be in an inconsistent state. – Hack5 Jun 4 '18 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.