I've been working on a file server product that uses smbcilent to transfer files between client computers and the server. It's been working great so far with our LAMP (Ubuntu) server and Windows machines.

I'm currently trying to expand the setup to include Mac's, but am having trouble with the server accessing the share on the Mac.

Here's my command and error (bracketed descriptions replace private info):

# smbclient //[share-file] -U [username]%[password] -c ls
WARNING: The "syslog" option is deprecated
NTLMSSP packet check failed due to short signature (0 bytes)!
NTLMSSP NTLM2 packet check failed due to invalid signature!
session setup failed: NT_STATUS_ACCESS_DENIED

Things I've tried:

✓ Accessing the Mac share using a Windows machine (instead of Ubuntu server) to ensure the share is setup properly - check! Works fine there.

✓ Invoking -S off or --signing=off in the command - no change.

✓ Just looking at the shares first using smbclient -L -U [username]%[password] - same error.

✓ Googling for an answer - check! Several people with similar problems, but no working solutions so far.

Thanks for reading and trying to help!


You must log in to answer this question.

Browse other questions tagged .