6

When I use mutt under Ubuntu like below, my email address is shown as maemo@maemo-TomXue. I want to change it but didn't find how to do, who could help me? Thanks!

y:Send q:Abort t:To c:CC s:Subj a:Attach file d:Descrip ?:Help

From: maemo maemo@maemo-TomXue
  To: hello@what.com
  Cc:
 Bcc:

Subject: 111 Reply-To: Fcc: ~/sent Mix: Security: None

-- Attachments - I 1 /tmp/mutt-maemo-desktop-1000-4182-199622
7

Either start reading up on mutt's configuration, or export EMAIL=my.address@example.com from your `.bashrc'

| improve this answer | |
2

As others have noted, it's most likely that the best way to address your situation is by editing ~/.muttrc appropriately. However, for those who stumble on this question looking for a "one-time" way to change the value of the 'From' header, you can simply use Esc f.

| improve this answer | |
1

The most standard way to do this is to use a ~/.muttrc file and add the following to it:

set from = "my_preferred_address@whatever.com"

And this should solve the problem... Other useful settings to use are:

 set realname="My RealName"
 set use_from=yes
 set envelope_from ="yes"

Have a look here for a discussion of the correct way to set "From" and other matters...

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.