2

This is probably a very simple issue, so sorry for bothering but I'm totally new to Ubuntu.

I have version Ubuntu 17.04.

I saw this thread and downloaded this file.

My biggest issue is that when I click "install" after double-clicking the .deb file, it doesn't do anything. Literally, nothing - the text doesn't even change to "installing".

I tried opening it with dpkg like propesed here (as it appears to be similar to my case), but I keep getting dependency errors (it requires package dkms, but when downloaded dkms itself also gives me dependency errors, and at this point I feel that I'm just doing it the wrong way)).

Sadly, the USB device is currently my only option of connecting to the internet on this PC, so all the packages so far I've had to get by downloading on another device and dropping it off by USB.

sudo lshw -class network shows only my integrated (Ethernet port only) network adapter.

lsusb lists this:

Bus 002 Device 002: ID 2357:010e

Oh, and in case this is relevant - this installation was done with the "nomodeset xforcevesa" command, as I have gotten freezes during normal installation.

I hope that I didn't forget anything important, and thank you for help in advance.

  • If you have installed 17.04, you need the zesty packages, not xenial. Please try dkms from here packages.ubuntu.com/zesty/dkms and tell us what the missing dependencies are. The packages in xenial nor zesty for rtl8812au-dkms do not cover your exact device, se we will need to use another method, ideally including dkms. – chili555 Jun 26 '17 at 14:58
  • @chili555 The device is not there yet. I created a "method". – Pilot6 Sep 4 '17 at 19:51
1

I forked rtl8812au driver and added the 2357:010e device.

Also I added dkms.conf to enable DKMS install.

You need to disable Secure Boot in BIOS if you are using UEFI, then run in a terminal:

sudo apt install git
git clone https://github.com/hanipouspilot/rtl8812au.git
sudo dkms add ./rtl8812au
sudo dkms install rtl8812au/0.1
0

In Ubuntu 18.04.1 the following worked perfectly for TP-Link T4UH ac1200 usb 3.0: https://askubuntu.com/a/1069805/389523

sudo apt-get install rtl8812au-dkms

then restart the computer, the receiver light should start blinking.

as it is a laptop, one should also disable the internal Wifi: you can look for the wifi kernel driver with:

lspci -nnk

then

sudo modprobe -r *the name of the internal wifi kernel driver*

in my case:

sudo modprobe -r iwlwifi

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.