1

Recently I realized the automatic time doesn't work.

I guess the battery that keeps the time in my computer is bad, so I need the system to take the right time from Internet.

I'm testing changing the year and it is not automatically fixed. I'm using Compiz. enter image description here

I'm pretty sure the problem is caused by Dual Boot (Windows/Ubuntu).

But in this moment I'm telling Ubuntu to take the time from Internet.

Why it doesn't work?

I think this must have a fix inside Ubuntu regardless of the dual boot.

  • 2
    Is it off by a consistent amount? If so see previous comment. Or does it drift? – Joe P Jun 25 '17 at 22:07
  • Joe P: Half an hour difference. Probaby related to recently installed Windows 8 (dual booting). I already fixed it, but I still have the doubt: Why Automatic Time doesn't work? – Shirley Temple Jun 29 '17 at 13:53
  • A fixed difference means Automatic Time is working, but your two OSes don't agree about understanding time zones. Have you read the "Clock time is off" answers? – Joe P Jun 29 '17 at 14:40
  • Joe P: Yes, I have read the "Clock time is off" answers. Then I changed Ubuntu to "local time". Now the two OSes uses the same time. But the automatic time seems not be working: If I manually change the time and then switch to automatic, the system doesn't fix the time. This bring us, again, to my question, which is not duplicated : Why Automatic Time doesn't work? – Shirley Temple Jun 30 '17 at 1:10
0

In KDE (Kubuntu), System Settings > Date & Time > check Set date and time automatically. You may want to adjust the NTP server to your region.

In Unity / Gnome the settings will be something similar.

| improve this answer | |
  • Please see this Screenshot. I'm testing changing the year and it is not automatically fixed. I'm using Compiz. – Shirley Temple Jun 25 '17 at 22:34
  • 1
    As I asked on the original question, is it off by a consistent amount? Or does it drift? It's still not clear whether you have a problem with not getting ntp time or with having the wrong time-zone offset (which the question linked as a duplicate will fully answer). – Joe P Jun 29 '17 at 11:38
  • Joe P: Half an hour difference. Probaby related to recently installed Windows 8 (dual booting). I already fixed it, but I still have the doubt: Why Automatic Time doesn't work? – Shirley Temple Jun 29 '17 at 13:53

Not the answer you're looking for? Browse other questions tagged or ask your own question.