I have installed tor successfully and Vidalia shows it is running without problems; however, when I check if I am using tor in this website I get an error message saying I am not using tor.

I have tried two things to fix this:

  1. I installed ProxySwitchy on Google Chrome, and created a profile for Tor (with address, port 8118), but enabling the proxy doesn't change the results in the tor check website linked before.

  2. I changed my network proxy settings through System Settings > Network from None to Manual, and selected as address always and as port 8118 for all but for the socket, for which I entered 9050 instead. This makes internet stop working completely.

How can I fix this problem?


What you need to configure is polipo/privoxy for tor as your are using http proxy. Tor doesnot use 8118 as its port it uses 9050 and it is a socks proxy. You can use this configuration for polipo to use with tor. Just do:

sudo wget https://gitweb.torproject.org/torbrowser.git/blob_plain/HEAD:/build-scripts/config/polipo.conf -O /etc/polipo/config

sudo service tor stop && sudo service polipo stop

sudo service tor start && sudo service polipo start

tor needs to start before polipo, or else polipo will occupy the 9050 port and tor will start with errors

I am giving much focus here on polipo because tor itself recommends polipo and is installed by default on tor installation. You can use privoxy in place of polipo as well. Most of the tor users recommend using the default socks proxy if the application handles it.

Go to the Network settings and select the proxy method to Manual. Set all addresses to and all ports to 8118, except for the socket port which needs to be 9050. With this setup, the following components are not necessary and not encouraged:

  • Browser proxy plugins
  • Vidalia

Whenever you want to use your direct connection again, refer to the Network settings and change the proxy method to None.

  • Ok, I have completed the steps you suggested, but how should I use polipo? I am still "not using" tor, according to the check page. Thanks in advance. – Severo Raz Jan 5 '12 at 5:53
  • Did you get any error during polipo/tor restart ? You donot need to use 9050 for browser use 8118 and make all connections follow the same proxy in browser proxy setting. In applications like thunderbird, xchat you can use socks directly. – sagarchalise Jan 5 '12 at 7:08
  • No, both restart processes completed successfully. My /etc/tor/torrc file has only the following 3 lines uncommented: SocksPort 9050; SocksListenAddress; ControlPort 8118, is that ok? I am setting a manual proxy in the Network settings but still no success. – Severo Raz Jan 5 '12 at 8:26
  • My torrc doesnot have control port you may not need that. – sagarchalise Jan 5 '12 at 9:26
  • Oh well, I added the control port because another configuration I had used (I think the one vidalia provided) had the control port. I have now removed it and started tor before polipo (without vidalia) and everything works! Thank you very much for your help. – Severo Raz Jan 5 '12 at 21:16

proxyswitchy will work fine, but instead of ticking the box for Use the same proxy server for all protocols, manually enter the same address ( port 8118) into http/https and ftp but for the Socks one use port 9050. This worked for me. Please don't forget to check it though on https://check.torproject.org/. :-)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.