0

I posted a problem of authentication for my hard drive at What does this authentication after login in LXDE mean?

I found someone said the problem was caused by lm-sensors which uses udisks2

It's caused by lm-sensors. Click on the thermometer indicator (which is lm-sensors) -> Preferences -> Providers -> Then untick 'Enable support of udisks2'. That seems to make it go away. It probably is still a configuration type bug, but I'm not sure if I really need the udisks2 reading for what I use lm-sensors for. Hope this helps!

I followed the advice, and opened the thermometer indicator (which is lm-sensors) -> Preferences -> Providers. I unticked Enable support of udisks2, and because I would like to check my hard drive temperature, I ticked Enable support for hddtemp daemon.

enter image description here

To understand what I was doing, I found https://wpitchoune.net/psensor/faq.html

For hard disk drives, psensor can use:

udisks2: added since 1.1.2 release. It is the default and recommended provider.

hddtemp: verify that it is correctly reporting temperature by using the command: sudo hddtemp /dev/sda. It is the default provider until 1.1.2 release.

atasmart library: before the 1.1.2 release it can be enabled by using the command line option --use-libatasmart.

How are hddtemp, udisks2 and libatasmart compared to each other? Do I miss something if I tick hddtemp and untick udisks2?

Thanks.

1

As you know they have nothing to do with each other, "psensor" is just a temperature monitoring application which uses other tools to gather its data.

For me because of permissions only udisks2 is working. anyway, you should test the output of these commands, if you get the same result (which you should) then there is no difference.

so they're just different sources.


As far as I know all of them gather their data using hard disk smart.

For "udisks2" use:

udiskctl dump /dev/sdX grep | -i temp

For "libsmart" you can look for smart data yourself, use:

sudo smartctl -a /dev/sdX | grep -i temp

And finally hddtemp /dev/sdX.

  • Thanks. I found that changing from udisks2 to hddtemp doesn't make the hard drive authentication go away. So i tried another solution which works askubuntu.com/questions/924421/… – Tim Jun 25 '17 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.