3

I was using Ubuntu 14.04 and Windows 10 in dual boot.

Suddenly there was a problem and I was unable to boot into any of them (both Ubuntu 14.04 and Windows 10). So I reinstalled Windows 10 and then I tried to reinstall Ubuntu.

I deleted the old ubuntu partition.Now I get the following error while installing ubuntu from cd.

"The partition table format in use on your disks normally requires you to create a separate partition for boot loader code. This partition should be marked for use as “Reserved BIOS boot area” and should be at least 1 MB in size. Note that this is not the same as a partition mounted on /boot. If you do not go back to the partitioning menu and correct this error, bootloader installation may fail later, although it may still be possible to install the boot loader to a partition."

It gives me two options :
1.Go back
2.Continue

What should I do?

I tried to install both in legacy mode and uefi mode but I get the same error.

5

The error message you report should NOT appear in an EFI/UEFI-mode boot, only in a BIOS/CSM/legacy-mode boot. Furthermore, when you're dual-booting with Windows, if that message appears, you should STOP IMMEDIATELY, because you're pretty much guaranteed to have bigger problems once the system is installed. The issue is this:

Windows ties its boot mode to its partition table type -- Windows will boot in BIOS mode only from MBR disks, and in EFI mode only from GPT disks. Ubuntu is not nearly so strict. The "reserved BIOS boot area" is a BIOS Boot Partition, which is a type of partition that's used to enable BIOS-mode booting from GPT disks. In a dual-boot setup, though, a GPT disk means that Windows is installed in EFI mode, and the request that you create a BIOS Boot Partition means that the Ubuntu installer is booted in BIOS mode, and is trying to set up a BIOS-mode boot. Booting Windows in EFI mode and Ubuntu in BIOS mode is possible, but doing so is an unnecessary complication.

Thus, what I recommend you do is:

  1. Enter your firmware setup utility and disable the CSM. The details of how to do this vary from one computer to another, but the option is usually called "CSM support," "legacy boot support," or something similar. In some cases, you'll see an item that refers to "boot mode," with options called "UEFI only," "UEFI and legacy," or "legacy only." You want to disable any "CSM" or "legacy" support, or set the boot mode to "UEFI only."
  2. Boot the Ubuntu installer and verify that it's in EFI mode. You can do this by booting to the "try before installing" mode, opening a Terminal, and looking for a directory called /sys/firmware/efi. If it's present, you've booted in EFI mode; if it's absent, you've booted in BIOS mode and you should try again.
  3. If you can't get booted in EFI mode, you may need to re-create your Ubuntu installation medium. See this page of mine for information on how to do this (and much more on the issue of the CSM generally). The difficulty is that some tools omit the EFI boot loader, or create a medium that confuses the firmware in a way that forces a BIOS-mode boot. If this happens, and you need to boot in EFI mode, the appropriate action is to adjust the options or even switch to another method of preparing the boot medium.

Note that, in many cases, the boot-mode options are more like suggestions than commands; the computer may fall back to booting in another mode even if you've told it to boot in one way only. It's more common to be unable to force a BIOS-mode boot than to be unable to force an EFI-mode boot, though.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.