1

I upgraded Ubuntu 16.04 to Ubuntu 17.04. Now I installed VirtualBox and am trying to make a Kali Linux virtual machine, but it is showing me this message:

This kernel requires an x86-64 CPU, but only detected an i686 CPU.
Unable to boot - Please use a kernel appropriate for your CPU.

I am running Dell Optiplex 745 with 3GB Ram.

VirtualBox screenshot

0
2

That message means your CPU is 32-bit, but the Kali image you are using is 64-bit. Use the 32-bit Kali image instead.

1
  • Dear i had tried the 32-bit image as well but it is still showing the same errot
    – Alcash
    Jul 2 '17 at 5:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.