1

When running sudo apt-get upgrade I get the following:

You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 conky-all : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 git : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 gstreamer0.10-plugins-bad : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 icecast2 : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 libquvi7 : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 libraptor2-0 : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 python-pycurl : Depends: libcurl3-gnutls (>= 7.24.0) but it is not installed
 transmission-gtk : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 vorbis-tools : Depends: libcurl3-gnutls (>= 7.16.2-1) but it is not installed
E: Unmet dependencies. Try using -f.

When I run apt-get -f install I get:

Selecting previously unselected package libcurl3-gnutls:amd64.
dpkg: unrecoverable fatal error, aborting:
 reading files list for package 'libebml3:amd64': Input/output error
E: Sub-process /usr/bin/dpkg returned an error code (2)

So I'm running dpkg --configure -a but I get:

Setting up libfreetype6:amd64 (2.4.9-1.1+deb7u7) ...
Bus error
dpkg: error processing libfreetype6:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up libxml2:amd64 (2.8.0+dfsg1-7+wheezy7) ...
Bus error
dpkg: error processing libxml2:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up libssl1.0.0:amd64 (1.0.1t-1+deb7u2) ...
Bus error
dpkg: error processing libssl1.0.0:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up libperl5.14 (5.14.2-21+deb7u5) ...
Bus error
dpkg: error processing libperl5.14 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up libffi5:amd64 (3.0.10-3+deb7u2) ...
Bus error
dpkg: error processing libffi5:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of libcairo2:amd64:
 libcairo2:amd64 depends on libfreetype6 (>= 2.3.5); however:
  Package libfreetype6:amd64 is not configured yet.

dpkg: error processing libcairo2:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libupnp6 (1:1.6.17-1.2+deb7u2) ...
Bus error
dpkg: error processing libupnp6 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up libgcrypt11:amd64 (1.5.0-5+deb7u5) ...
Bus error
dpkg: error processing libgcrypt11:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of icecast2:
 icecast2 depends on libcurl3-gnutls (>= 7.16.2); however:
  Package libcurl3-gnutls is not installed.
 icecast2 depends on libxml2 (>= 2.7.4); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing icecast2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libbind9-80:
 libbind9-80 depends on libxml2 (>= 2.6.27); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing libbind9-80 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgd2-xpm:amd64:
 libgd2-xpm:amd64 depends on libfreetype6 (>= 2.2.1); however:
  Package libfreetype6:amd64 is not configured yet.

dpkg: error processing libgd2-xpm:amd64 (--configure):
 dependency problems - leaving unconfigured
Setting up libtasn1-3:amd64 (2.13-2+deb7u4) ...
Bus error
dpkg: error processing libtasn1-3:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of printer-driver-hpijs:
 printer-driver-hpijs depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing printer-driver-hpijs (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of dnsutils:
 dnsutils depends on libbind9-80 (= 1:9.8.4.dfsg.P1-6+nmu2+deb7u16); however:
  Package libbind9-80 is not configured yet.
 dnsutils depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0:amd64 is not configured yet.
 dnsutils depends on libxml2 (>= 2.6.27); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing dnsutils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of hpijs:
 hpijs depends on printer-driver-hpijs; however:
  Package printer-driver-hpijs is not configured yet.

dpkg: error processing hpijs (--configure):
 dependency problems - leaving unconfigured
Setting up libxapian22 (1.2.12-2+deb7u1) ...
Bus error
dpkg: error processing libxapian22 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up libwbclient0:amd64 (2:3.6.6-6+deb7u13) ...
Bus error
dpkg: error processing libwbclient0:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of libgail-3-0:amd64:
 libgail-3-0:amd64 depends on libcairo2 (>= 1.10.0); however:
  Package libcairo2:amd64 is not configured yet.
 libgail-3-0:amd64 depends on libfreetype6 (>= 2.2.1); however:
  Package libfreetype6:amd64 is not configured yet.

dpkg: error processing libgail-3-0:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of openssl:
 openssl depends on libssl1.0.0 (>= 1.0.1e-2+deb7u20); however:
  Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing openssl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of printer-driver-hpcups:
 printer-driver-hpcups depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0:amd64 is not configured yet.

dpkg: error processing printer-driver-hpcups (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxslt1.1:amd64:
 libxslt1.1:amd64 depends on libgcrypt11 (>= 1.4.5); however:
  Package libgcrypt11:amd64 is not configured yet.
 libxslt1.1:amd64 depends on libxml2 (>= 2.7.4); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing libxslt1.1:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libisc84:
 libisc84 depends on libxml2 (>= 2.7.4); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing libisc84 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmagickcore5-extra:amd64:
 libmagickcore5-extra:amd64 depends on libcairo2 (>= 1.6.0); however:
  Package libcairo2:amd64 is not configured yet.
 libmagickcore5-extra:amd64 depends on libfreetype6 (>= 2.2.1); however:
  Package libfreetype6:amd64 is not configured yet.
 libmagickcore5-extra:amd64 depends on libxml2 (>= 2.7.4); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing libmagickcore5-extra:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rtmpdump:
 rtmpdump depends on libgcrypt11 (>= 1.4.5); however:
  Package libgcrypt11:amd64 is not configured yet.

dpkg: error processing rtmpdump (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-common:
 grub-common depends on libfreetype6 (>= 2.2.1); however:
  Package libfreetype6:amd64 is not configured yet.

dpkg: error processing grub-common (--configure):
 dependency problems - leaving unconfigured
Setting up libgif4 (4.1.6-10+deb7u1) ...
Bus error
dpkg: error processing libgif4 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of libisccfg82:
 libisccfg82 depends on libisc84; however:
  Package libisc84 is not configured yet.
 libisccfg82 depends on libxml2 (>= 2.6.27); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing libisccfg82 (--configure):
 dependency problems - leaving unconfigured
Setting up libmagic1:amd64 (5.11-2+deb7u9) ...
Bus error
dpkg: error processing libmagic1:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of ntfs-3g:
 ntfs-3g depends on libgcrypt11 (>= 1.4.5); however:
  Package libgcrypt11:amd64 is not configured yet.

dpkg: error processing ntfs-3g (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libfontconfig1:amd64:
 libfontconfig1:amd64 depends on libfreetype6 (>= 2.2.1); however:
  Package libfreetype6:amd64 is not configured yet.

dpkg: error processing libfontconfig1:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of grub-pc-bin:
 grub-pc-bin depends on grub-common (= 1.99-27+deb7u3); however:
  Package grub-common is not configured yet.

dpkg: error processing grub-pc-bin (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libmagickwand5:amd64:
 libmagickwand5:amd64 depends on libfontconfig1 (>= 2.9.0); however:
  Package libfontconfig1:amd64 is not configured yet.
 libmagickwand5:amd64 depends on libfreetype6 (>= 2.2.1); however:
  Package libfreetype6:amd64 is not configured yet.

dpkg: error processing libmagickwand5:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgimp2.0:
 libgimp2.0 depends on libcairo2 (>= 1.10.2); however:
  Package libcairo2:amd64 is not configured yet.
 libgimp2.0 depends on libfontconfig1 (>= 2.9.0); however:
  Package libfontconfig1:amd64 is not configured yet.
 libgimp2.0 depends on libfreetype6 (>= 2.2.1); however:
  Package libfreetype6:amd64 is not configured yet.

dpkg: error processing libgimp2.0 (--configure):
 dependency problems - leaving unconfigured
Setting up libgstreamer-plugins-base0.10-0:amd64 (0.10.36-1.1+deb7u2) ...
Bus error
dpkg: error processing libgstreamer-plugins-base0.10-0:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up libslp1 (1.2.1-9+deb7u1) ...
Bus error
dpkg: error processing libslp1 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of file:
 file depends on libmagic1 (= 5.11-2+deb7u9); however:
  Package libmagic1:amd64 is not configured yet.

dpkg: error processing file (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgsf-1-114:
 libgsf-1-114 depends on libxml2 (>= 2.7.4); however:
  Package libxml2:amd64 is not configured yet.

dpkg: error processing libgsf-1-114 (--configure):
 dependency problems - leaving unconfigured
Setting up libc6-i386 (2.13-38+deb7u12) ...
Bus error
dpkg: error processing libc6-i386 (--configure):
 subprocess installed post-installation script returned error exit status 135
Setting up liblcms2-2:amd64 (2.2+git20110628-2.2+deb7u2) ...
Bus error
dpkg: error processing liblcms2-2:amd64 (--configure):
 subprocess installed post-installation script returned error exit status 135
dpkg: dependency problems prevent configuration of php5-cgi:
 php5-cgi depends on libssl1.0.0 (>= 1.0.0); however:
  Package libssl1.0.0:amd64 is not configured yet.
 php5-cgi depends on libxml2 (>= 2.8.0); however:
  Package libxml2:amd64 is not configured yet.
 php5-cgi depends on libmagic1; however:
  Package libmagic1:amd64 is not configured yet

.
.
.
..
...
many lines skiped
...
..
.
.
.


dpkg: error processing php5-curl (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libtiff-tools:
 libtiff-tools depends on libtiff5 (>> 4.0.0-1~); however:
  Package libtiff5:amd64 is not configured yet.

dpkg: error processing libtiff-tools (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxi6:amd64:
 libxi6:amd64 depends on libx11-6 (>= 2:1.4.99.1); however:
  Package libx11-6:amd64 is not configured yet.

dpkg: error processing libxi6:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exiv2:
 exiv2 depends on libexiv2-12; however:
  Package libexiv2-12 is not configured yet.

dpkg: error processing exiv2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libswscale2:amd64:
 libswscale2:amd64 depends on libavutil51 (>= 6:0.8.3-1~); however:
  Package libavutil51:amd64 is not configured yet.

dpkg: error processing libswscale2:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libavdevice53:amd64:
 libavdevice53:amd64 depends on libavcodec53 (>= 6:0.8.3-1~) | libavcodec-extra-53 (>= 6:0.8.20); however:
  Package libavcodec53:amd64 is not configured yet.
  Package libavcodec-extra-53 is not installed.
 libavdevice53:amd64 depends on libavformat53 (>= 6:0.8.3-1~); however:
  Package libavformat53:amd64 is not configured yet.
 libavdevice53:amd64 depends on libavutil51 (>= 6:0.8.3-1~); however:
  Package libavutil51:amd64 is not configured yet.
 libavdevice53:amd64 depends on libx11-6 (>= 2:1.4.99.1); however:
  Package libx11-6:amd64 is not configured yet.

dpkg: error processing libavdevice53:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of lynx:
 lynx depends on lynx-cur (>= 2.8.8dev.12-2+deb7u1); however:
  Package lynx-cur is not configured yet.

dpkg: error processing lynx (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of apache2-mpm-prefork:
 apache2-mpm-prefork depends on apache2.2-common (= 2.2.22-13+deb7u8); however:
  Package apache2.2-common is not configured yet.
 apache2-mpm-prefork depends on apache2.2-bin (= 2.2.22-13+deb7u8); however:
  Package apache2.2-bin is not configured yet.

dpkg: error processing apache2-mpm-prefork (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libxfixes3:amd64:
 libxfixes3:amd64 depends on libx11-6 (>= 2:1.4.99.1); however:
  Package libx11-6:amd64 is not configured yet.

dpkg: error processing libxfixes3:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libnss3-1d:amd64:
 libnss3-1d:amd64 depends on libnss3 (= 2:3.26-1+debu7u4); however:
  Package libnss3:amd64 is not configured yet.

dpkg: error processing libnss3-1d:amd64 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of printer-driver-postscript-hp:
 printer-driver-postscript-hp depends on hplip (>= 3.12.6-3.1+deb7u2); however:
  Package hplip is not configured yet.

dpkg: error processing printer-driver-postscript-hp (--configure):
 dependency problems - leaving unconfigured
Setting up texlive-latex-base-doc (2012.20120611-5+deb7u1) ...
dpkg: dependency problems prevent configuration of apache2:
 apache2 depends on apache2-mpm-worker (= 2.2.22-13+deb7u8) | apache2-mpm-prefork (= 2.2.22-13+deb7u8) | apache2-mpm-event (= 2.2.22-13+deb7u8) | apache2-mpm-itk (= 2.2.22-13+deb7u8); however:
  Package apache2-mpm-worker is not installed.
  Package apache2-mpm-prefork is not configured yet.
  Package apache2-mpm-event is not installed.
  Package apache2-mpm-itk is not installed.
 apache2 depends on apache2.2-common (= 2.2.22-13+deb7u8); however:
  Package apache2.2-common is not configured yet.

dpkg: error processing apache2 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of exim4:
 exim4 depends on exim4-daemon-light | exim4-daemon-heavy | exim4-daemon-custom; however:
  Package exim4-daemon-light is not configured yet.
  Package exim4-daemon-heavy is not installed.
  Package exim4-daemon-custom is not installed.

dpkg: error processing exim4 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of zendframework:
 zendframework depends on php5 | php5-cli; however:
  Package php5 is not configured yet.
  Package php5-cli is not configured yet.

dpkg: error processing zendframework (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of gir1.2-gdkpixbuf-2.0:
 gir1.2-gdkpixbuf-2.0 depends on libgdk-pixbuf2.0-0 (>= 2.25.2); however:
  Package libgdk-pixbuf2.0-0:amd64 is not configured yet.

dpkg: error processing gir1.2-gdkpixbuf-2.0 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libopencv-imgproc2.3:
 libopencv-imgproc2.3 depends on libopencv-core2.3 (= 2.3.1-11+deb7u1); however:
  Package libopencv-core2.3 is not configured yet.

dpkg: error processing libopencv-imgproc2.3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of sane-utils:
 sane-utils depends on libsane (>= 1.0.11-3); however:
  Package libsane:amd64 is not configured yet.

dpkg: error processing sane-utils (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libpython2.7:
 libpython2.7 depends on python2.7 (= 2.7.3-6+deb7u3); however:
  Package python2.7 is not configured yet.

dpkg: error processing libpython2.7 (--configure):
 dependency problems - leaving unconfigured
Processing triggers for tex-common ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time... done.
Running mktexlsr /var/lib/texmf ... done.
Setting up texlive-latex-base (2012.20120611-5+deb7u1) ...
Running mktexlsr. This may take some time... done.
Building format(s) --all --cnffile /etc/texmf/fmt.d/10texlive-latex-base.cnf.
        This may take some time... done.
Setting up texlive-metapost (2012.20120611-5+deb7u1) ...
Setting up texlive-luatex (2012.20120611-5+deb7u1) ...
Processing triggers for tex-common ...
Running mktexlsr. This may take some time... done.
Running updmap-sys. This may take some time... done.
Running mktexlsr /var/lib/texmf ... done.
Setting up perl-modules (5.14.2-21+deb7u5) ...
Setting up perl (5.14.2-21+deb7u5) ...
Setting up libdpkg-perl (1.16.18) ...
Setting up libsoap-lite-perl (0.714-1+deb7u1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-4-amd64
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/usb-common.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/usb-common.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-jumpshot.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-jumpshot.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-karma.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-karma.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-cypress.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-cypress.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-realtek.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-realtek.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-eneub6250.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-eneub6250.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-sddr09.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-sddr09.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-datafab.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-datafab.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-sddr55.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-sddr55.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-alauda.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-alauda.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-isd200.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-isd200.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-onetouch.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-onetouch.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-freecom.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-freecom.ko': Input/output error
Bus error
install: reading `/lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-usbat.ko': Input/output error
install: failed to extend `/var/tmp/mkinitramfs_k0lCUc//lib/modules/3.2.0-4-amd64/kernel/drivers/usb/storage/ums-usbat.ko': Input/output error
Bus error
depmod: ../libkmod/libkmod-elf.c:207: elf_get_mem: Assertion `offset < elf->size' failed.
Aborted
Processing triggers for menu ...
Errors were encountered while processing:
 libfreetype6:amd64
 libxml2:amd64
 libssl1.0.0:amd64
 libperl5.14
 libffi5:amd64
 libcairo2:amd64
 libupnp6
 libgcrypt11:amd64
 icecast2
 libbind9-80
 libgd2-xpm:amd64
 libtasn1-3:amd64
 printer-driver-hpijs
 dnsutils
 hpijs
 libxapian22
 libwbclient0:amd64
 libgail-3-0:amd64
 openssl
 printer-driver-hpcups
 libxslt1.1:amd64
 libisc84
 libmagickcore5-extra:amd64
 rtmpdump
 grub-common
 libgif4
 libisccfg82
 libmagic1:amd64
 ntfs-3g
 libfontconfig1:amd64
 grub-pc-bin
 libmagickwand5:amd64
 libgimp2.0
 libgstreamer-plugins-base0.10-0:amd64
 libslp1
 file
 libgsf-1-114
 libc6-i386
 liblcms2-2:amd64
 php5-cgi
 libwmf0.2-7:amd64
 libebml3:amd64
 php5-gd
 libsmbclient:amd64
 libmagick++5:amd64
 libcairo-gobject2:amd64
 libsqlite3-0:amd64
 libgtk-3-0:amd64
 libnspr4:amd64
 libexpat1:amd64
 gstreamer0.10-plugins-bad:amd64
 libarchive12:amd64
 gstreamer0.10-plugins-ugly:amd64
 libass4:amd64
 liblwres80
 libidn11:amd64
 libxml2-utils
 python2.7-minimal
 ntfsprogs
 libtiff5:amd64
 libtiff4:amd64
 librtmp0:amd64
 libaudiofile1:amd64
 libsystemd-login0:amd64
 libgs9
 libkrb5support0:amd64
 wget
 bind9-host
 libgme0
 librsvg2-2:amd64
 libpoppler-glib8:amd64
 ntp
 debootstrap
 libsndfile1:amd64
 libmpg123-0:amd64
 libhpmud0
 nginx-full
 libcurl3:amd64
 nginx
 libimlib2
 libminiupnpc5
 librsvg2-common:amd64
 openvpn
 apache2-utils
 libc6-dev-i386
 libtidy-0.99-0
 libx11-6:amd64
 libgtk-3-bin
 libjasper1:amd64
 openssh-server
 openjdk-6-jre-headless:amd64
 libavfilter2:amd64
 libcroco3:amd64
 libplist1
 libgnutls26:amd64
 xsltproc
 poppler-utils
 grub-pc
 openjdk-6-jre:amd64
 openjdk-6-jre-lib
 libavutil51:amd64
 python-magic
 samba-common-bin
 ghostscript
 libx11-dev:amd64
 liblcms1:amd64
 libc-ares2:amd64
 xscreensaver
 git
 monit
 libmp3lame0:amd64
 mpg123
 libjbig2dec0
 libx11-xcb1:amd64
 libavformat53:amd64
 apache2.2-common
 python-imaging
 libexiv2-12
 php5-cli
 libapache2-mod-php5
 apache2.2-bin
 libldap-2.4-2:amd64
 gstreamer0.10-plugins-base:amd64
 libnss3:amd64
 libicu48:amd64
 imagemagick
 libxtst6:amd64
 libpostproc52:amd64
 libnspr4-0d:amd64
 libisccc80
 python-libxml2
 libnettle4:amd64
 lynx-cur
 openssh-client
 libevent-2.0-5:amd64
 ntpdate
 ghostscript-cups
 php5
 grub2-common
 gstreamer0.10-plugins-good:amd64
 libpng12-0:amd64
 gir1.2-gtk-3.0
 libdns88
 libpixman-1-0:amd64
 libpoppler19:amd64
 lame
 icedtea-6-jre-cacao:amd64
 libonig2
 gstreamer0.10-x:amd64
 libopencv-core2.3
 hplip
 libpcsclite1:amd64
 binutils
 gstreamer0.10-alsa:amd64
 libgstreamer-plugins-bad0.10-0:amd64
 libkrb5-3:amd64
 libssh2-1:amd64
 gimp
 libmagickcore5:amd64
 suckless-tools
 libpq5
 libsane-hpaio
 libsane:amd64
 xscreensaver-data
 libavcodec53:amd64
 fontconfig
 libgssapi-krb5-2:amd64
 php5-pgsql
 libav-tools
 ssl-cert
 dpkg-dev
 libmatroska5:amd64
 libgdk-pixbuf2.0-0:amd64
 libmp3lame-dev:amd64
 libk5crypto3:amd64
 libxrender1:amd64
 openjdk-6-jdk:amd64
 libxvmc1
 libxpm4:amd64
 python-aptdaemon.gtk3widgets
 ffmpeg
 libxrandr2:amd64
 exim4-daemon-light
 python2.7
 libxv1:amd64
 curl
 php-pear
 php5-curl
 libtiff-tools
 libxi6:amd64
 exiv2
 libswscale2:amd64
 libavdevice53:amd64
 lynx
 apache2-mpm-prefork
 libxfixes3:amd64
 libnss3-1d:amd64
 printer-driver-postscript-hp
 apache2
 exim4
 zendframework
 gir1.2-gdkpixbuf-2.0
 libopencv-imgproc2.3
 sane-utils
 libpython2.7

I've done a lot of research but I cannot fix this.


I am using ssh so I can't use Synaptic manager. sudo apt-get check returns:

Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 conky-all : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 git : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 gstreamer0.10-plugins-bad : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 icecast2 : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 libquvi7 : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 libraptor2-0 : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 python-pycurl : Depends: libcurl3-gnutls (>= 7.24.0) but it is not installed
 transmission-gtk : Depends: libcurl3-gnutls (>= 7.16.2) but it is not installed
 vorbis-tools : Depends: libcurl3-gnutls (>= 7.16.2-1) but it is not installed
E: Unmet dependencies. Try using -f.

Also I can't install gedit because it returns the same error as above.

4
  • First of all, start by running sudo apt-get update to update package database. Then run sudo apt-get upgrade and update your questions withthe outputifthereare any errors.
    – Soren A
    Jun 24, 2017 at 22:00
  • yeah, i forgot to mention this. I had already run sudo apt-get update before running the above
    – george n.
    Jun 24, 2017 at 22:18
  • See the part of the initial error message that says Input/Output error? Bad news - sometimes indicating hardware failure. Look up how to run a SMART test on your HDD to rule out hardware failure. If your disk tests good, then try installing libcurl3-gnutls again.
    – user535733
    Jun 25, 2017 at 9:09
  • 2
    Does this answer your question? Package dbus is not configured yet
    – Melebius
    Dec 17, 2019 at 7:58

1 Answer 1

5

Try opening Synaptic manager and check for broken packages and remove them if any. Also, you can try:

sudo apt-get check

If the lost dependencies error resume, you can try this:

sudo gedit /var/lib/dpkg/status

Then you can delete the depends packages by search and delete.


Update after your comment:

To fix the broken dependencies without using Synaptic manager issue the following commands:

sudo apt-get update --fix-missing

sudo dpkg --configure -a

then

sudo apt-get install -f 

If the problem resumes, you can try the above command by editing status file manually, and because you use ssh, try different non-graphical editors like nano or vim or any other. Try this:

sudo nano /var/lib/dpkg/status

Then remove the whole block of information belonging to each broken package.

5
  • i am using ssh so i cant use synaptic manager. sudo apt-get check returns too many lines so i posted a reply
    – george n.
    Jun 24, 2017 at 22:45
  • @geprge n , did you try to install these missing packages ? and tell me if you tried to run 32 architecture packages or not Jun 25, 2017 at 2:18
  • @george please review the answer again , i have update it after your comment Jun 25, 2017 at 2:31
  • It seems the double dash was lost in your anwer for --configure and --fix-missing , can you fix it so people can copy / paste the commands Oct 31, 2019 at 17:55
  • @blackjack75 You could have suggested the edit yourself (and gained 2 reputation points…)
    – Melebius
    Dec 17, 2019 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.