0

After upgrading from 16.10 to 17.04, I get through the grub menu, then get stuck at a black screen with 5 squares on it, each square with a dot that is either red or white. The page cycles through these dots, changing them from white to red, then back to white.

I can't find anything about this page anywhere on the internet, so I don't know what it's trying to convey to me.

I can ssh in over the network to this node, so the system is up, but it doesn't respond to mouse, keyboard - just cycles through the dots. Have looked at all the logs in /var/log but don't see anything odd. So no login screen, no desktop. I've included a picture.

I'm running an Nvidia graphics card. Haven't changed anything regarding that from when I upgraded from 16.10 to 17.04, and it worked on 16.10.

after boot - no mouse, no keyboard, cycles through dot colors

0

Try to ssh to your node and reinstall X server with

sudo apt-get install --reinstall xserver-xorg

and also Nvidia drivers

sudo apt-get purge nvidia-*
sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
udo apt-get install nvidia-375

I had exactly the same issue and this fixed it, let´s hope that it will fix your machine too.

3
  • Tomas, thanks for your help! That got me past that point, but lightdm.service is failing. I also recognize the squares on the picture now - they are part of the Ubuntu splash screen. Getting past that now, but as I said, stuck afterwards. Last error message on syslog is failed to start light display mangers. lightdm.service: unit entered failed state. – user2565677 Jun 24 '17 at 20:44
  • Try reinstalling LightDM with this command: sudo apt-get install --reinstall lightdm-gtk-greeter – Tomáš Tomovčík Jun 25 '17 at 9:33
  • It turned out to be something different. My graphics card was an Asus Matrix GTX 580 (Nvidia chipset), although the Nouveau would work, but was far to slow to use. None of the drivers (I tried them all) would work on 17.04 for me. I ended up buying a new graphics card, (NVIDIA Corporation GP107 [GeForce GTX 1050 Ti]) and it works with the driver in 17.04. – user2565677 Aug 2 '17 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.