Recently, I was trying to install scipy, but I stopped the prpcess in midway. After that, ubuntu always start with grub recovery menu. Then, when I tried to resolve the issue with disk check, clean and other options... It doesnt resolve.

In dpkg, i get bus error or error that python is missing a variable.

When i boot ubuntu in recovery mode, i can not see any applications in Dash. I have used sudo apt-get clean, autoclea,, auto remove, update, upgrade, -f update but it all ends with list of all applications with unmet dependencies and package reading error and that there is corrupted cache.

I tried using the gnome-software....software center... and removed the softwares but they dont. They appear again.

I noticed that i can use the application if i try to Open.it from.terminal butvi cannot install anything.

Please help. I am new to ubuntu. I have to starta project on Python soon.


Someone maybe able to provide a better answer, but if you still have your original install media, you can reset your OS back to a default state and it should keep all your documents. However, it's never a bad idea to back them up.

  • I dont have it right now. thats the problem. I have the backup, but i was wondering if it could be resolved without the os reinstall. Otherwise, i would have to download ubuntu and the, resolve it. – NSarkar Jun 23 '17 at 20:10

First clean the corrupted apt lists:

sudo rm -r /var/lib/apt/lists/*

Then run sudo apt update

The problem will be solved

  • I have tried this. This didnt work for me. – NSarkar Jun 23 '17 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.