2

This is the same problem from 6 years ago and 5 years ago. Let me quote the linked question.

I have sound working and I have the Login Sound working but I don't get any other alert/notification sounds. E.g. if a question box pops up - there's no sound.

The 6-year-old solution (compiz configuration) doesn't work for me. The one provided 5 years ago (using Ubuntu tweak) is outdated and particularly not suited for Xfce. I have figured that it has probably something to do with the fact that beep doesn't work on my system. Neither does echo -e "\a" succeed in producing any audible sound. However, the PulseAudio command line interface works pretty well. I can do something like paplay path/to/audio/file.ogg to produce a sound from a bash script, for example.

However, the problem is that notifications from some applications don't work using PulseAudio. Therefore, they go unheard most of the times.

What should I do? Why hasn't there been any improvement since six years?


EDIT:

  1. I noticed that even the login sound does not work for me.

  2. I updated the following values in the system settings.

    settings editor

    For this to work properly, I installed gnome-session-canberra, ubuntu-sounds, sox, xfconf, without one bit of progress.

  3. I tried adding the following to autostart. No success here as well!

    indicator sound

  4. Heck I reinstalled the entire xubuntu-desktop to see if I messed something up. But it hasn't improved the situation one bit.

I am still missing important notification sounds. Many apps (for example, email clients such as nylas-mail) cannot even send notifications. I am starting to think that this is a bug in the Xubuntu distro itself. Should I report this bug? Or can I fix this?

2
+50

I do not think your description is accurate. I could reproduce the following with a fresh install of Xubuntu 16.04.

  1. Changing of volume does not involve any sound notifications.

  2. Changing brightness by scrolling on the battery icon does not show any indicator notification. However, changing it by means of a keyboard does trigger a notification.

Please purge Nylas Mail (or the likes) and reinstall to check if notifications are still mute. In my case, they weren't.

In summary, you could register your problems probably as feature requests or bug reports (I am not sure which is appropriate). Alternatively, you can ask a question here regarding however you want to manually customise your notification preferences. Be specific about what you want.

  • I wonder if it is like that by design. Anyway, I think I can live with these limitations for now, given that all other important notifications are working perfectly. – Nanashi No Gombe Jul 7 '17 at 8:24
1

I had the same problem and solved it last night by following these directions I found on Ubuntu forums(they won't let me add an image) ... https://ubuntuforums.org/showthread.php?t=1869787 ... also I see you have not named your "sound theme name" in Settings Editor - X Settings. And be sure to check dconf Editor - org.gnome.desktop.sound and make sure event sounds & input-feedback-sounds are checked and theme name is correct (in this case ubuntu). I had to add theme sound twice before everything worked but it works now :) This would of been much easier and more informative if I was allowed to post screenshots .. Sorry and good luck to you, let me know if this works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.