Installed a new user and then tried to create one with the name root, because sudo nerves. Didnot work and i have learnt in the meantime, this is not possible.

I am now unable to login into user "admin". It complains that /home/marek/.ICEauthority could not be updated.

I have another user which can login. sudo under the new user does not work and it complains a unsuccessful attempt has been reported.

How can I fix the .ICEAuthority permissions to use this login? > SOLUTION: First log in on terminal with ctrl+alt+F1 as admin, so this was possible, only on destop not. Second gave me all rights in /home/marek back with boldsudo chmod -R u+rw /home/marek. For me it seems, that the error message shows .ICEauthority file and there no rw-rights for admin, but really during my triing to create a root-account ubuntu has deleted my admin-rights somewhere else, because i was still admin and could change user-accounts and have given back only me all rw-rights. Sounds a little bit strange.

  • forgot:ubuntu 11.10 64bit. As installer i am admin, but on the terminal i am not root, instead marek, and this seemed not to work as root, so i used sudo: but this is debian style only, so confusion. – Marek Jan 4 '12 at 20:36
  • what was the first user you created? – viyyer Jan 4 '12 at 20:41

Root is the first user created in almost every distribution. So please do not try to create a root user.

To run applications as root including shell(which means basically means becoming root) in Ubuntu all one needs is to run sudo. Sudo is very useful.

sudo application_name options 

This is the way to use sudo. to solve the ICE issue. You need to change the ownership of the file to the user running the shell. Type this command.

 sudo chown marek:marek /home/marek/.ICEauthority

I assume marek is the username as it is in the directory /home/marek. Login as the first user created while setting up Ubuntu and then run the sudo chown command as above.

Corrections: the marek does not need to be the first user. Though the password would be the password of the one is in. Corrections: Added changes for users who are not in sudoers list.

| improve this answer | |
  • please check the edits above – viyyer Jan 4 '12 at 20:49
  • no go new user doesn´t allow sudo – Marek Jan 4 '12 at 20:49
  • well. login as admin user and run the command as given above. – viyyer Jan 4 '12 at 20:50
  • marek, new one is standard martin – Marek Jan 4 '12 at 20:51
  • 1
    @Marek Can you update your question with what you are trying instead of burying it in comments? Your question is very hard to read, we need you to summarize your problem better up front so we can help! – Jorge Castro Jan 4 '12 at 22:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.