0

I'm lost. I cannot find the answer I need anywhere. I updated to 4.4.0-81 and ever since doing so I cannot access many of my installed software. Nothing happens. No errors coming up. I would like to get back to 4.4.0-77 which worked fine. I made the mistake of purging the functional kernel before testing. I cannot figure out how to roll-back.

My system was stable as can be with the older Kernel. How can I go back?

linux-headers-4.4.0-81 4.4.0-81.104~14.04.1 all Header files related to Linux kernel version 4.4.0

ii linux-headers-4.4.0-81-generic 4.4.0-81.104~14.04.1 amd64 Linux kernel headers for version 4.4.0 on 64 bit x86 SMP

ii linux-headers-generic-lts-xenial 4.4.0.81.66

  • they should be in the repository, install the old ones and remove the new ones – ravery Jun 22 '17 at 15:51
0

Start synaptic and search for the kernel id you want. I could not find 4.4.0-77 so I used 4.4.0-78 for this example. Select the 4 packages shown for your kernel.

enter image description here

Install them, then reboot. Hold left shift to get the grub menu if you don't have it displayed by default. Select Advanced Options for Ubuntu from the grub menu and select the kernel you want.

FYI, in general, it is a good idea to keep at least the last old kernel around, in case stuff like this happens.

  • I usually do keep the old Kernel. Not sure why I didn't this time. But what you suggested was so simple, I had no Idea I could do that. Unfortunately I was doing all of that remotely, edited my grub conf file, set it to select the older kernel, and the computer did not come back online after a remote reboot. It could be because i messed up the grub conf file selection, but since I'm not in front of the computer, I do not know what is on the screen now. Thanks for the help. – Dave Solecki Jun 22 '17 at 16:43
  • You're welcome. If it worked for you, please accept and/or upvote the answer I gave! – Organic Marble Jun 22 '17 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.