1

I just installed lubuntu 17.04 without problems. The pc also connects to my wifi, but I can not go to any websites in firefox (or search for updates etc.).

I tried connecting it to the router with an ethernet cable, which gave the same result.

I can ping the DNS ip adress (127.0.0.53) without problems.

I have tried removing the battery and waiting a bit again as recommended on other pages.

What should I try next? I am new to ubuntu.

Best,

  • I have the same Problem on a fresh install on an acer Extensa 5220 – rubo77 Jul 17 '17 at 12:17
0

You can solve this temporarily by adding some needed IPs to your /etc/hosts file, for example:

sudo su
echo "security.ubuntu.com 91.189.91.23">>/etc/hosts
echo "us.archive.ubuntu.com 91.189.91.23">>/etc/hosts
echo "de.archive.ubuntu.com 141.76.1.200">>/etc/hosts
echo "google.com 172.217.22.206">>/etc/hosts
echo "google.de 172.217.22.195">>/etc/hosts

Then you can use your browser and apt without a working DNS to fix the issue:

export DEBIAN_FRONTEND=noninteractive
apt-get update
apt-get dist-upgrade

(use export DEBIAN_FRONTEND=noninteractive for this upgrade, otherwise you can run into problems on the console)

After a reboot DNS will start working correctly.


Additional info: At first I did this:

sudo systemctl disable systemd-resolved.service 

as suggested here and rebooted, but that didn't help, but it could be needed for my solution to work.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.