0

My Logitech M557 bluetooth mouse does not pair with Ubuntu 16.04 LTS.

I opened the Bluetooth settings window of Ubuntu, which indicates that Bluetooth is "On". I selected the "+" button to start the Device Search for all device types. I turned on the power switch of the M557 mouse and then pressed the "pair" button, which starts its blue pairing light to blink. The M557 is not found by the search.

I changed the device type to "Input devices" in the Device Search window, but the result is no better.

Also, I attempted to pair a JBL speaker, and that did not work. Bose headphones do not pair either. I also changed the "Visibility" switch for the computer in the Bluetooth settings window, which did not help.

The computer is a Dell Inspiron 15.

Any help would be greatly appreciated.

===== as requested additional information ====

06:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
    Subsystem: Dell Wireless 1704 802.11n + BT 4.0 [1028:0016]
    Kernel driver in use: wl
    Kernel modules: bcma, wl
Bus 001 Device 006: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller
Bus 001 Device 005: ID 0a5c:21d7 Broadcom Corp. BCM43142 Bluetooth 4.0
Bus 001 Device 004: ID 0bda:5756 Realtek Semiconductor Corp. 
Bus 001 Device 003: ID 045e:0084 Microsoft Corp. Basic Optical Mouse
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
  • Could you please add a little more detail? What exactly did you do, what did you want to achieve and what happened instead? Did you encounter any warning or error messages? Please reproduce them in their entirety in your question. You can select, copy and paste terminal content and most dialogue messages in Ubuntu. (see How do I ask a good question?) – David Foerster Jun 24 '17 at 18:02
  • Please edit your question and add output of lspci -knn | grep Net -A3; lsusb terminal command. – Pilot6 Jun 26 '17 at 8:49
  • askubuntu.com/questions/632336/… – Pilot6 Jul 4 '17 at 12:10
  • That Broadcom firmware update solution was CRAZY NUTS to follow, but it worked!!! I actually paired a new Logitech M535 mouse, rather than the mouse that started with, but either way it is solved! Much much thanks Pilot6! – warrens Jul 4 '17 at 13:23
0

sudo apt-get install solaar

That's for the Logitech mouse.

As far as the JBL speaker, it may have a button on it with a bluetooth icon; press and hold for a few seconds to make the device discoverable. (some bose speakers have that)

  • Solaar is for the Logitech Unifying receiver that plugs into the USB port. My Logitech mouse is Bluetooth. – warrens Jul 4 '17 at 11:53

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.