enter image description here

Clearly there is a problem rendering bold fonts in the terminal.The gedit version of Monaco looks much better,and is rendered properly.

I have also tried the Monaco font on Gvim,and terminator.They have the same issue(not being rendered properly). Only gedit seems to render it properly.

What could be the reason and is there a way to fix it?

  • Is it just Terminator or does Gnome-Terminal have the problem too? – Oli Jan 4 '12 at 18:12
  • 1
    Could you elaborate on what the issue is exactly? Maybe I just don't know fonts, but I don't really see an issue. I guess the middle picture looks a little blurry. Is that the problem? The first font doesn't seem blurry though. – Kris Harper Jan 4 '12 at 18:18
  • @root45 As I have mentioned,Monaco font is not rendered properly in terminal(or terminator or gvim) but looks great on Gedit. – Mad-scientist Jan 4 '12 at 18:23
  • 3
    @Mad-scientist Yes and I asked if you could elaborate more. Like I said, from your pictures I literally cannot see what is being rendered incorrectly. It looks fine to me, but you start your question with "clearly". – Kris Harper Jan 4 '12 at 18:27
  • 2
    @Mad-scientist - no its not obvious to me either - can you expand the pictures and highlight what you think is wrong. They look fine to me. – fossfreedom Jan 8 '12 at 19:10

I do not really see a problem here, although I concede the rendering is different.

Does this effect also occur with other fonts? The problem may be the following: The Monaco font that I was able to get my hands on simply does not have a bold variant. That would mean the bold must be faked, and different renderers seem to come to quite different results.


Have you tried playing with the profile options in terminator? I just had a look and found an option for "Anti-alias text". Maybe you could try that and see if it makes the font look as you expect it to look.

To find the option,

  • right click on the terminator window,
  • select "Preferences"
  • choose the "Profiles" tab
  • under the "General" (sub) tab there is an option called "Anti-alias" text.

Terminator preferences

This is in version 0.95 of terminator. I did have a quick look and couldn't find any corresponding option in gnome terminal or gedit.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.