0

I'm completely new to the Ubuntu world (I'm using Ubuntu 16.04). I encountered a very annoying problem when trying to install software. When I run

sudo apt-get application_name

nothing happens(installation freezes at 10% or whatever whatch here I'm just a beginner so i don't know how to fix it. In usc all the apps have disappeared(except the apps already installed). Just a suggestion:it might be a problem with my sources? Please help me to find and fix the issue.

3
  • 1
    Could you please update your question with the full output of sudo apt-get update and sudo apt-get upgrade ?
    – Soren A
    Jun 22, 2017 at 7:44
  • please post the output of these commands: sudo dpkg --configure -a , sudo apt-get install -f and cat /etc/apt/sources.list Jun 22, 2017 at 9:41
  • You can use a pastie service for the output of apt-get update etc. to not trigger the spam filter for too many URLs. Jun 22, 2017 at 10:23

1 Answer 1

0

To resolve the current packaging problem remove the oracle-java9-installer package:

sudo LC_MESSAGES=POSIX dpkg -r oracle-java9-installer && sudo LC_MESSAGES=POSIX apt-get install -f

This should enable you to install packages again.

If you need help installing Oracle Java 9 please open a new question about it specifically.

5
  • I tried to remove oracle java 9 installer but i receive this:E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. Jun 22, 2017 at 10:03
  • then run sudo dpkg --configure -a Jun 22, 2017 at 10:09
  • @fernandinho: Please try the commands in my updated answer. If there's still an error message please edit your question to include the full, verbatim output of the command that resulted in an error. Thanks. Jun 22, 2017 at 10:10
  • @fernandinho: Could you please edit your question, when you want to add information like I requested? Especially file or program output listings (with the help of the {} button in the editor toolbar) will be much more readable there; alternatively you can use a pastie service for longer listings and include the link of your pastie in your question. Overall it’s best to have everything relevant in one place. Additionally, comments may be deleted for various reasons. Thanks. Jun 22, 2017 at 10:35
  • after removing java9 -set-default and java9 instaler:florindobre@florindobre-MS-7387:~$ sudo apt-get install banshee [sudo] password for florindobre: Citire liste de pachete... Terminat Se construiește arborele de dependență Se citesc informațiile de stare... Terminat Pachetul banshee nu este disponibil, dar este menționat de către alt pachet. Aceasta ar putea însemna că pachetul lipsește, s-a învechit, sau este disponibil numai din altă sursă E: Package 'banshee' has no installation candidate Jun 22, 2017 at 10:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.