9

I have been using LibreOffice writer without any trouble until today. With no warning it simply refuses to open any documents with writer. All other suites are working fine, I can open calc fine, but as soon as I try a text document, the whole thing crashes. If I start with Writer it gives me a splash screen and then nothing, not even a crash report.

No other issues with OS. I have Lubuntu with latest updates. Very old laptop but has never been slow enough to cause crashes

  • did you try to start libreoffice.writer from a terminal in order to see if you get some useful error message? – Andrea Borga Jun 24 '17 at 20:52
  • I did, that's what's puzzling. No output, good or bad. It simply launches the splash screen and then returns to prompt after program crashes. Where would the error logs be for libreoffice? – Mateo B. Jun 24 '17 at 22:45
  • The problem may be with linux kernel - linux-image-4.4.0-81-generic (in Xenial) contains a fix for the Stack Clash vulnerability but break user-space programs. Have you tried with newest kernel update? I have linux-image-4.4.0-83-generic installed, and I can run libreoffice --writer normally. – N0rbert Jul 3 '17 at 15:20
15

I had the same issue on Arch linux (32bit xfce) https://bbs.archlinux.org/viewtopic.php?id=227597

I've managed to solve it by turning off Java in Libreoffice>

First, start Libreoffice, click on Tools, click on options and under Libreoffice section click on Advanced. Deselect "Use a Java runtime environment" and problem solved.

I don't think this a good solution, but considering I don't use Java in Libreoffice it's good enough for me.

  • You rock! This fixed the issue and is my accepted answer since it had the details. Even though there is likely a better answer to fix LO with java this will do for now. – Mateo B. Jun 25 '17 at 20:11
  • Worked like a charm. Thanks. Why is LO using Java in the first place? – Abid H. Mujtaba Jul 21 '17 at 9:40
  • This is a known issue in the kernel/JVM code. Bug #1699772 tracks the issue. Until this is properly fixed, the best workaround is to turn off java in libreoffice, indeed. – Olivier Tilloy Sep 14 '17 at 12:27
  • Same symptoms as OP. I think a reinstalled Libreoffice 3 times, deleted the profile files 42 times, and this is the only bullet proof solution. Thank you ! – Laurent W. Mar 3 at 16:04

protected by Community Jun 26 '17 at 8:48

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.