4

I wanted to install an Ubuntu Server in my Virtual Box, the installation works fine but after I reboot to start the VBox I get a black Screen. I already have tried reinstalling it but nothing works.

I installed Vbox on Windows 7 64bit PC. The VBox for Ubuntu has 3GB RAM and 10 GB VHD.

My startup on Ubuntu picture:

MY STARTUP ON UBUNTU Picture

9 Answers 9

5

I had the same issue on Windows 10 host when I installed Docker it automatically enabled Hyper-V and the Ubuntu Guest Os beahved exactly like you describe, nothing helped but disabling Hyper-V in Windows 10 host settings - Win+R ->OptionalFeatures.exe -> uncheck Hyper-V

2
  • Just uninstalling Hyper-V in windows features didn't help in my case, it was still enabled after the uninstallation. Had to update my Windows 10 Pro to version 20H2
    – axk
    Apr 18, 2021 at 12:55
  • @FantomX1 I opened the OptionalFeatures but Hyper-V is already unchecked.
    – Sandun
    May 19, 2021 at 8:53
3

I solved my problem (Ubuntu 18.04) increasing the Video Memory to 128MB on Virtual Machine settings (Settings / Display / Video Memory)

Default value is 16Mb.

1
  • Increasing to 32MB solved the issue for me. Apr 16, 2019 at 18:01
2

Did you install ubuntu as 64 bit or 32 bit?

In the case that you installed it as 64 bit do this:

  • Open Virtual Box

    Select your virtual machine and click in "Configurations"

    Go to "General"

    Change the version to "Ubuntu (64-bit)"

2
  • 1
    I installed it as 64 bit and it is already selected
    – Amundi
    Jun 21, 2017 at 15:24
  • Have you tried switching tty while the VM is powered on? ctrl + alt + f1 or f7. Do they propagate any change?
    – jamieg
    Jun 23, 2017 at 11:19
1

note for my future self and whomever may have this problem:

If you have both Hyper V and Virtual Box, the virtualization mechanisms will conflict. You can let the virtualization on at your bios/uefi setup but you'll need to turn Hyper V off at "Turn windows features on or off" at your start menu.

0

I have solved the problem by reinstalling with a GRUB Loader after that everything went as normal

1
  • 1
    Welcome to Ask Ubuntu! I recommend to edit this answer to expand it with specific details about how to do this. (See also How do I write a good answer? for general advice about what sorts of answers are considered most valuable on Ask Ubuntu.) Jun 21, 2017 at 22:47
0

As just you start your ubuntu in vm When black screen shows Press and hold shift key + repeatedly press the window key This will open your option menu Select advance Ubuntu option Then select recovery mode Select normal boot(first) option

1
  • If you need any further help plz reply me i will. Be available for you Jun 15, 2019 at 1:47
0

I had the same problem in Debian and I solve it by a specific choice in the GRUB installation enter image description here

You shouldn't choose "Enter device manually" You have to choose the second suggested option.

0

WSL2 might be the culprit!

My environment is newer than OP's, so this answer is directed to future readers encountering the same symptom as OP.

  • Windows 10 Home v2004 x64
  • Ubuntu 20.04 installed on WSL2 v2.0.0.20200910
  • VirtualBox 6.1.16 r140961 (Qt5.6.2)

VB has worked fine on this machine historically, but I hadn't been using it for a while when I installed WSL2. After trying VB again to boot into an old VM that had worked before, I was greeted with the black screen with blinking cursor as shown by OP.

In the past, I've solved this sort of thing by increasing video memory, enabling acceleration, changing the architecture size, etc. This time, nothing worked.

Eventually, I came across this Stack Overflow thread which basically says WSL2 and VB can't run at the same time because they compete for the hypervisor.

I followed the advice in this answer to disable WSL2 and rebooted, and VB was operational once again:

  • Press Win+r to open the Run dialog
  • Type OptionalFeatures.exe and click OK to open the Windows Features dialog
  • Uncheck "Virtual Machine Platform" and "Windows Subsystem for Linux" and click OK
  • Wait a bit while the features are disabled, then reboot when prompted. VB should work.

Re-enable the two features above to reverse the process and get back to a working WSL2 setup (disabling VB).

Unfortunately, the process takes time and a reboot and I don't see a way a way for the two to run simultaneously. Hopefully this will be addressed (see issue #798 WSL2 breaks VirtualBox 6.1).

Tested 1/30/21

0

Just FYI: Also Windows Sandbox feature causes issue with Ubuntu installation on VB (as it's also virtualization feature).

Type OptionalFeatures.exe and click OK to open the Windows Features dialog -> Uncheck "Windows Sandbox"

Not the answer you're looking for? Browse other questions tagged or ask your own question.