1

If I run Software Updater via System Tools I receive:

Not all updates can be installed, run a partial upgrade to install as many updates as possible.

I can choose: "settings", "partial upgrade" and "continue".

If I click "continue" I receive: "The software on this computer is up to date".

If I click "partial upgrade" I receive: "can't install lubuntu-core. It was impossible to install a required package". I can click Ok, and if I do so I receive: "do you want to start the upgrade?". In the packages to remove there are arduino, texworks and others (I don't understand why!).

Any suggestion?

Output sudo apt-get update:

Get:1 http://cran.mirror.garr.it xenial/ InRelease [3.590 B]                   
Hit http://archive.ubuntu.com xenial InRelease                                 
Hit http://security.ubuntu.com xenial-security InRelease
Ign http://cran.mirror.garr.it xenial/ InRelease     
Hit http://archive.ubuntu.com xenial-updates InRelease
Ign http://cran.mirror.garr.it xenial/ Packages/DiffIndex
Hit http://archive.ubuntu.com xenial/main amd64 Packages                
Hit http://security.ubuntu.com xenial-security/main amd64 Packages             
Hit http://archive.ubuntu.com xenial/main i386 Packages                        
Hit http://security.ubuntu.com xenial-security/main i386 Packages   
Hit http://archive.ubuntu.com xenial/main Translation-en            
Hit http://security.ubuntu.com xenial-security/main Translation-en  
Hit http://archive.ubuntu.com xenial/main Translation-it            
Hit http://cran.mirror.garr.it xenial/ Packages                     
Hit http://archive.ubuntu.com xenial-updates/main amd64 Packages
Hit http://archive.ubuntu.com xenial-updates/main i386 Packages
Hit http://archive.ubuntu.com xenial-updates/main Translation-en
Ign http://cran.mirror.garr.it xenial/ Translation-en_US                       
Ign http://cran.mirror.garr.it xenial/ Translation-en                          
Ign http://cran.mirror.garr.it xenial/ Translation-it                          
Fetched 3.590 B in 6s (573 B/s)                                                
Reading package lists... Done
N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
W: GPG error: http://cran.mirror.garr.it xenial/ InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 51716619E084DAB9

Output sudo apt-get upgrade:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... The following packages were automatically installed and are no longer required:
  libavahi-client-dev libavahi-common-dev libdbus-1-dev libllvm3.6v5 libpango1.0-0 python-cffi python-ply python-pycparser
Use 'apt-get autoremove' to remove them.
Done
The following packages have been kept back:
  apt apt-transport-https apt-utils aptitude aptitude-common apturl apturl-common bind9-host bluez-obexd cups cups-bsd cups-client cups-core-drivers cups-daemon
  cups-filters cups-filters-core-drivers curl debhelper default-jre default-jre-headless dnsutils emacs24 emacs24-bin-common emacs24-common findutils gdebi-core
  gir1.2-gtk-3.0 glib-networking glib-networking-common glib-networking-services gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-x gvfs gvfs-backends
  gvfs-bin gvfs-common gvfs-daemons gvfs-fuse gvfs-libs inkscape isc-dhcp-client isc-dhcp-common libappindicator1 libcups2 libcupscgi1 libcupsimage2 libcupsmime1
  libcupsppdc1 libcurl3-gnutls libgail18 libgd3 libgnomevfs2-0 libgnomevfs2-common libgnomevfs2-extra libgnutls-openssl27 libgpgme11 libgpod4
  libgstreamer-plugins-base1.0-0 libgstreamer-plugins-good1.0-0 libgstreamer1.0-0 libgtk-3-0 libgtk-3-bin libgtk2.0-0 libgtk2.0-bin libgtkmm-3.0-1v5
  libhsqldb1.8.0-java libhunspell-1.3-0 libinput10 libjs-jquery libldap-2.4-2 libmirclient9 libneon27-gnutls libnm-glib-vpn1 libnm-glib4 libnm-gtk-common libnm-gtk0
  libnm-util2 libnm0 libpoppler-qt4-4 libqt4-dbus libqt4-declarative libqt4-designer libqt4-network libqt4-opengl libqt4-qt3support libqt4-script libqt4-scripttools
  libqt4-sql libqt4-svg libqt4-xml libqt4-xmlpatterns libqt5core5a libqt5dbus5 libqt5gui5 libqt5network5 libqt5printsupport5 libqt5qml5 libqt5quick5 libqt5sql5
  libqt5sql5-sqlite libqt5svg5 libqt5widgets5 libqt5xml5 libqtcore4 libqtdbus4 libqtgui4 librtmp1 libsmbclient libvdpau1 libvncclient1 libvte-2.91-0
  libvte-2.91-common libwbclient0 libwpd-0.10-10 libyelp0 lp-solve lsb-release network-manager network-manager-gnome ntfs-3g ntfs-3g-dev printer-driver-gutenprint
  procps python-apt python-gi python-service-identity python3-apt qdbus qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-layouts
  qml-module-qtquick-privatewidgets qml-module-qtquick-window2 qml-module-qtquick2 qpdf ruby samba-libs ttf-ancient-fonts-symbola tzdata upower yelp zenity
  zenity-common
0 upgraded, 0 newly installed, 0 to remove and 144 not upgraded.
N: Ignoring file '50unattended-upgrades.ucf-old' in directory '/etc/apt/apt.conf.d/' as it has an invalid filename extension
  • Please open a terminal (ctrl-alt-t) and run sudo apt update & sudo apt upgrade and update your question with the output of these .. they basically do the same as Software-updater, but in text mode instead. – Soren A Jun 21 '17 at 12:20
  • it's a dependency chain, it can't install lubuntu -core so the packages that depend on it are removed, and the ones depending those and so on. Labuntu-core is the base of your desktop, it will remove the entire desktop if you let it run. – ravery Jun 21 '17 at 12:22
  • @ravery Not good. How can I resolve that problem? – zar Jun 21 '17 at 12:25
  • you need to find out what the problem with lubuntu -core is.is it being held maybe? – ravery Jun 21 '17 at 12:27
  • @ravery I can't understand sorry – zar Jun 21 '17 at 12:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.