3

I have a keyboard/mouse Logitech Wireless Desktop MK270 that works very well. I recently bought this USB stick. When I plug it in, the mouse is inhibited: the cursor disappears completely. When I unplug the key, everything goes back to normal. The stick is not mounted automatically when plugged in.

I run Ubuntu 16.04. Here is the output of lsusb with the stick plugged in:

Bus 002 Device 008: ID 0781:5583 SanDisk Corp. 
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 009: ID 046d:c534 Logitech, Inc. Unifying Receiver
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I tried to plugging the stick and keyboard/mouse receiver into different ports, but it's the same.

I tested the stick on other computers:

  • Raspberry Pi 3B without keyboard/mouse: the stick is mounted automatically read/write, but it's unwritable.
  • Old computer 16.04 with USB2.0 and wired keyboard/mouse: works as expected. I copied 45GB of videos on it without problem.
  • DVD/BlueRay reader: the stick works as expected.

So it seems to be a sort of incompatibility between the stick and the USB receiver.

9
  • 1
    some bios has certain configuration about usb 3.0 port, especially in some new motherboard. could you check it?
    – adadion
    Jun 21, 2017 at 11:36
  • I have a Asrock deskmini 110 computer. I saw some settings in the BIOS about UEFI and XHCI, both disabled. The stick was formatted as FAT32, I reformatted it as NTFS, now it is mounted automatically, but the mouse problem is the same.
    – albar
    Jun 21, 2017 at 11:53
  • 1
    if xhci disabled, usb 3.0 port will operate in 2.0 standard ehci mode. And uefi has nothing to do about your problem. So, try to enabled xhci mode in your bios.
    – adadion
    Jun 21, 2017 at 12:16
  • Thnks, good to know. I enabled XHCI, but the problem is the same. I made further tests and edited my question.
    – albar
    Jun 21, 2017 at 13:07
  • 2
    I do search some thread, it seems your usb wireless interfere the frequency of 3.0 usb devices. See this and this one has good explanation. According to those article, the possible solution is extending your usb port using usb extension cable (adjust to some range where there is not produce any frequency interfere any more.)
    – adadion
    Jun 22, 2017 at 6:35

2 Answers 2

3

According this and this good explanation, there is possibility of frequency interfere caused 3.0 usb devices that affecting any of wireless mouse and keyboard.

So the possible solution is extending your usb port using usb extension cable (adjust to some range where there is not produce any frequency interfere any more. *Tips: place the receiver as close as possible to the wireless device)

5
  • that seems unlikely as the cursor would not completely vanish because of RFI.
    – Wug
    Jun 22, 2017 at 9:29
  • 1
    @Wug I'm afraid it does. See on OP's comment on his post :)
    – adadion
    Jun 22, 2017 at 9:32
  • It might also be the case that the USB extension kit (cable or cable + adapter) is recognized correctly and activates a driver, that works well with the two conflicting USB devices. Anyway, you found a solution :-)
    – sudodus
    Jun 22, 2017 at 9:34
  • 2
    The receiver was plugged behind the central unit, the stick front. I simply plugged the receiver to a standard USB cable extension, then put the receiver very near my mouse/keyboard. It works like a charm.
    – albar
    Jun 22, 2017 at 9:44
  • Not having a good connection shouldn't cause the cursor to disappear. I've seen interference before and I can't fathom why a poor signal would cause the OS to stop drawing the mouse cursor, something it continues to do even with no mouse connected at all.
    – Wug
    Jun 30, 2017 at 8:29
0

I sometimes have to use a Lenovo Ideapad 320 if I need to work from home. I have Ubuntu MATE 18.04 on a USB stick plugged into either of the only two available USB3 ports (no USB 2.0 port) on the left side of the laptop. When the USB stick is busy reading/writing files, my wireless mouse whose dnngle is plugged in beside it behaves erratically.

Searching further, I learned about the interference and the possible mitigation. Sadly, I do not have a USB extension cord neither another USB port on the right side of the laptop.

What I did was wrap the entire body of the USB with a piece of foil. The reflective surface should be on the outside. That did the trick for me.

USB3 stick w/ foil

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.