I'm on Ubunut 17.04 with Gnome shell 3.24.2. Ever since the fresh install, the clock got placed to the right side of the top panel. I have not found a way to move it to the center. I'm aware of this and this post, but they both didn't help. For one - I don't have system-monitor extension installed and I can't find the extension in /.local/share/gnome-shell/extensions or /usr/share/gnome-shell/extensions/ that causes this behavior in the first place.

Is the clock at the right side default in 17.04 or is this just my system? Seems a terrible choice.

I just encountered the same problem, and found a fix.

In /usr/share/gnome-shell/modes there's a classic.json file that holds the configuration for the current shell -

{
    "parentMode": "user",
    "stylesheetName": "gnome-classic.css",
    "enabledExtensions": [LIST_OF_STUFF],
    "panel": { "left": ["activities", "appMenu"],
               "center": [],
               "right": ["a11y", "keyboard", "dateMenu", "aggregateMenu"]
             }
}

All you need to do is to move the "dateMenu" item to the center. I also had the Window List extension enabled after every boot, and removing it here solved the problem.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.