My friend just convinced me into installing ubuntu. Ubuntu installation went fine, but after the installation no wireless networks are detected. I have tried to:

  • restart the network-manager and reboot, this didn't work
  • than I tried to install the driver according to: How do I get a Realtek RTL8723BE wireless card to work? but installing the driver gave the following error:

    ~$ sudo dpkg -i rtlwifi*.deb
    (Reading database ... 174667 files and directories currently installed.)
    Preparing to unpack rtlwifi-new-dkms_0.10_all.deb ...
    Deleting module version: 0.10
    completely from the DKMS tree.
    Unpacking rtlwifi-new-dkms (0.10) over (0.10) ...
    Setting up rtlwifi-new-dkms (0.10) ...
    Loading new rtlwifi-new-0.10 DKMS files...
    First Installation: checking all kernels...
    Building only for 4.8.0-36-generic
    Building for architecture x86_64
    Building initial module for 4.8.0-36-generic
    ERROR: Cannot create report: [Errno 17] File exists: '/var/crash/rtlwifi-new-dkms.0.crash'
    Error! Bad return status for module build on kernel: 4.8.0-36-generic (x86_64)
    Consult /var/lib/dkms/rtlwifi-new/0.10/build/make.log for more information.

Can anyone help me with my wireless network connection and/or with installing the driver, please?

I don’t know if this is useful information but windows does show several available network connections. Thus, network is available and hardware is not broken.

  • 1
    Delete /var/crash/rtlwifi-new-dkms.0.crash and edit your question to include the terminal output of cat /var/lib/dkms/rtlwifi-new/0.10/build/make.log and dkms status. Ping me at @heynnema. – heynnema Jun 20 '17 at 21:00
  • 1
    I don't think you need to compile any driver at all in kernel 4.8 and later. Please edit your question to add the result of the terminal command 'sudo modprobe rtl8723be' and also 'rfkill list all' Welcome to Ask Ubuntu. – chili555 Jun 20 '17 at 22:33
  • Is this a newer HP computer? – Jeremy31 Jun 20 '17 at 22:37
  • 1
    Thanks guys, it appears that just the signals appeared too weak. Changing the antenna solved this: [askubuntu.com/questions/914048/… Just saving the settings (the last step) doesn't work :( – ChriMoo Jun 22 '17 at 17:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.