0

I've upgrade from 15.10 to 16.04.2 LTS. After upgrade I've 20 broken packages.

If I try sudo apt-get -f install I obtain

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  evolution-data-server evolution-data-server-online-accounts
  fonts-crosextra-caladea fonts-crosextra-carlito fonts-stix gstreamer1.0-nice
  inputattach libabw-0.1-1v5 libaccounts-glib0 libboost-date-time1.58.0
  libclucene-contribs1v5 libcmis-0.5-5v5 libe-book-0.1-1 libebackend-1.2-10
  libebook-1.2-16 libecal-1.2-18 libedata-book-1.2-25 libedata-cal-1.2-27
  libeot0 libetonyek-0.1-1 libexttextcat-2.0-0 libexttextcat-data
  libfarstream-0.2-5 libfreehand-0.1-1 libgdata-common libgdata22
  libgeocode-glib0 libglew1.10 libglew1.13 libgoa-1.0-0b libgoa-1.0-common
  libgweather-3-6 libgweather-common libhsqldb1.8.0-java libhyphen0
  liblangtag-common liblangtag1 libmspub-0.1-1 libmwaw-0.3-3 libmythes-1.2-0
  liboauth0 libodfgen-0.1-1 liborcus-0.10-0v5 libpagemaker-0.0-0 libpoppler58
  libpython3.5 libreoffice-avmedia-backend-gstreamer libreoffice-base
  libreoffice-base-core libreoffice-base-drivers libreoffice-calc
  libreoffice-common libreoffice-core libreoffice-draw libreoffice-gnome
  libreoffice-gtk libreoffice-impress libreoffice-java-common libreoffice-math
  libreoffice-pdfimport libreoffice-report-builder-bin
  libreoffice-sdbc-firebird libreoffice-sdbc-hsqldb libreoffice-style-breeze
  libreoffice-style-galaxy libreoffice-writer libservlet3.0-java
  libsignon-glib1 memtest86+ printer-driver-pnm2ppa python3-uno rfkill
  uno-libs3 ure x11-apps x11-session-utils xinit xorg
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  gir1.2-atk-1.0 hplip-data initramfs-tools-core libcdr-0.1-1 libglew1.13
  libmwaw-0.3-3 libodfgen-0.1-1 liborcus-0.10-0v5 libplymouth4
  libpython2.7-minimal libpython2.7-stdlib libpython3.5 libreadline6
  libreadline6-dev libsnmp30 linux-base plymouth plymouth-label
  plymouth-theme-ubuntu-text printer-driver-hpcups python2.7 python2.7-minimal
  xserver-common xserver-xorg-video-amdgpu
Suggested packages:
  glew-utils readline-doc desktop-base plymouth-themes hplip-doc python2.7-doc
  binfmt-support firmware-amd-graphics
The following packages will be REMOVED:
  libcdr-0.1-1v5 libmwaw-0.3-3v5 libodfgen-0.1-1v5
  linux-image-extra-3.19.0-84-generic lubuntu-core plymouth-theme-lubuntu-text
The following NEW packages will be installed:
  initramfs-tools-core libcdr-0.1-1 libglew1.13 libmwaw-0.3-3 libodfgen-0.1-1
  libpython3.5 linux-base plymouth xserver-xorg-video-amdgpu
The following packages will be upgraded:
  gir1.2-atk-1.0 hplip-data liborcus-0.10-0v5 libplymouth4
  libpython2.7-minimal libpython2.7-stdlib libreadline6 libreadline6-dev
  libsnmp30 plymouth-label plymouth-theme-ubuntu-text printer-driver-hpcups
  python2.7 python2.7-minimal xserver-common
15 upgraded, 9 newly installed, 6 to remove and 833 not upgraded.
36 not fully installed or removed.
Need to get 0 B/16.2 MB of archives.
After this operation, 154 MB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 303116 files and directories currently installed.)
Removing linux-image-extra-3.19.0-84-generic (3.19.0-84.92) ...
depmod: FATAL: could not load /boot/System.map-3.19.0-84-generic: No such file or directory
run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.19.0-84-generic /boot/vmlinuz-3.19.0-84-generic
run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.19.0-84-generic /boot/vmlinuz-3.19.0-84-generic
update-initramfs: Generating /boot/initrd.img-3.19.0-84-generic
/usr/sbin/update-initramfs: 172: /usr/sbin/update-initramfs: mkinitramfs: not found
update-initramfs: failed for /boot/initrd.img-3.19.0-84-generic with 127.
run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 127
dpkg: error processing package linux-image-extra-3.19.0-84-generic (--remove):
 subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
 linux-image-extra-3.19.0-84-generic
E: Sub-process /usr/bin/dpkg returned an error code (1)

The problem seems to be linux-image-extra-3.19.0-84-generic.

If I try apt-get autoremove I obtain:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 hplip : Depends: hplip-data (= 3.16.3+repack0-1) but 3.15.7-0ubuntu4 is installed
         Depends: printer-driver-hpcups (= 3.16.3+repack0-1) but 3.15.7-0ubuntu4 is installed
 initramfs-tools : Depends: initramfs-tools-core (= 0.122ubuntu8.8) but it is not installed
                   Depends: linux-base but it is not installed
 libatk1.0-dev : Depends: gir1.2-atk-1.0 (= 2.18.0-1) but 2.16.0-2build1 is installed
 libhpmud0 : Depends: libsnmp30 (>= 5.7.3+dfsg-1ubuntu3~dfsg) but 5.7.3+dfsg-1ubuntu2 is installed
 libpython2.7 : Depends: libpython2.7-stdlib (= 2.7.12-1ubuntu0~16.04.1) but 2.7.10-4ubuntu1 is installed
 libreadline-dev : Depends: libreadline6-dev (= 6.3-8ubuntu2) but 6.3-8ubuntu1 is installed
 libreoffice-calc : Depends: libmwaw-0.3-3 but it is not installed
                    Depends: libodfgen-0.1-1 but it is not installed
                    Depends: liborcus-0.10-0v5 (>= 0.9.2-4ubuntu2) but 0.9.2-3ubuntu3 is installed
 libreoffice-core : Depends: libglew1.13 (>= 1.12.0) but it is not installed
 libreoffice-draw : Depends: libcdr-0.1-1 but it is not installed
                    Depends: libmwaw-0.3-3 but it is not installed
                    Depends: libodfgen-0.1-1 but it is not installed
 libreoffice-impress : Depends: libmwaw-0.3-3 but it is not installed
                       Depends: libodfgen-0.1-1 but it is not installed
 libreoffice-writer : Depends: libmwaw-0.3-3 but it is not installed
                      Depends: libodfgen-0.1-1 but it is not installed
 libsnmp30 : Depends: libperl5.20 (>= 5.20.2) but it is not installable
 lightdm : Depends: plymouth (>= 0.8.8-0ubuntu18) but it is not installed
 linux-image-extra-3.19.0-84-generic : Depends: linux-image-3.19.0-84-generic but it is not installable
 lubuntu-core : Depends: plymouth-theme-lubuntu-logo but it is not installable
                Recommends: acpi-support but it is not installed
                Recommends: bluez-cups but it is not installed
                Recommends: fonts-guru but it is not installed
                Recommends: fonts-kacst-one but it is not installed
                Recommends: fonts-khmeros-core but it is not installed
                Recommends: fonts-lao but it is not installed
                Recommends: fonts-lklug-sinhala but it is not installed
                Recommends: fonts-sil-abyssinica but it is not installed
                Recommends: fonts-sil-padauk but it is not installed
                Recommends: fonts-takao-pgothic but it is not installed
                Recommends: fonts-thai-tlwg but it is not installed
                Recommends: fonts-tibetan-machine but it is not installed
                Recommends: kerneloops-daemon but it is not installed
                Recommends: pcmciautils but it is not installed
                Recommends: printer-driver-brlaser but it is not installed
                Recommends: printer-driver-c2esp but it is not installed
                Recommends: printer-driver-foo2zjs but it is not installed
                Recommends: printer-driver-min12xxw but it is not installed
                Recommends: printer-driver-ptouch but it is not installed
                Recommends: printer-driver-pxljr but it is not installed
                Recommends: printer-driver-sag-gdi but it is not installed
                Recommends: printer-driver-splix but it is not installed
                Recommends: ttf-indic-fonts-core but it is not installable
 plymouth-label : Depends: plymouth (= 0.9.0-0ubuntu9) but it is not installed
 plymouth-theme-lubuntu-text : Depends: plymouth but it is not installed
 plymouth-theme-ubuntu-text : Depends: plymouth but it is not installed
 python3-uno : Depends: libpython3.5 (>= 3.5.0~b1) but it is not installed
 xserver-xorg-core : Depends: xserver-common (>= 2:1.18.4-0ubuntu0.2) but 2:1.17.2-1ubuntu9.1 is installed
 xserver-xorg-video-all : Depends: xserver-xorg-video-amdgpu
                          Recommends: xserver-xorg-video-qxl
E: Unmet dependencies. Try using -f.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.