4

I have a MacPro (6,1) machine with dual Tahiti GPUs that I need to run Ubuntu 16.04. The machine presently locks up on boot because the radeon drivers load before some necessary UEFI info is present. It will boot with "nomodeset", but I can't use that because the software I need to run relies heavily on the GPU. Fedora 24+ boots on the machine without issue, but I can't use that because the company's software that I need to test are all precompiled for Ubuntu 16.04 (and packaged Debian-style). Is there some way I can change the boot order? Make the radeon drivers wait longer? Make the boot more like Fedora?

As a desperate attempt, I made my Fedora install host virtual Ubuntu installation. I used the vfio passthrough for one of the GPUs. That does run, but I can't figure out how to attach a monitor to that hardware passthrough. All the Thunderbolt and HDMI plugs display Fedora. The GPUs are set in crossfire mode too; that may make it impossible to use one without the other. I don't know how to disable that in this MacPro hardware either.

Two other things I tried with no success: installing dracut and adding rd.driver.pre=applesmc.

1

1 Answer 1

0

I got this to work. After reading around, I realized it really was a bootloader (aka, Grub2) problem. I installed rEFInd and disabled Grub2, and it now works fine. rEFInd had "nomodeset" by default, but I was able to remove that by modifying /boot/refind_linux.conf . I also modified the refind.conf file to exclude the Mac partition as I didn't need any of those options.

These pages were helpful:

https://wiki.ubuntu.com/EFIBootLoaders

Can I safely remove grub after installing rEFInd?

Radeon driver: Can't run without "nomodeset" on MacPro6,1 with two AMD R9 280X Tahiti video cards

1

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .