0

I am trying to change the permissions for a folder outside my home directory in Ubuntu 14.04. by mistake I run the command "sudo chmod -R -777 /" in the terminal and my system crashes. Nothing is appearing on the screen. I have restarted it several times by but always a purple blank screen appears.

What can I do to recover from this. It contains lot of data related to my project.please help me.

marked as duplicate by muru, karel, Zanna, Eric Carvalho, Charles Green Jun 28 '17 at 13:35

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

migrated from stackoverflow.com Jun 20 '17 at 16:01

This question came from our site for professional and enthusiast programmers.

0

Run an OS off of a CD on the machine and recover your files by navigating the partition and copying them to a USB. Not sure how to recover your OS, but you can backup the partitions using TestDisk or Gnome-Disks.

  • I have Ubuntu in my pendrive can I use that. And by using the pendrive how should I run the OS – sanyam agarwal Jun 18 '17 at 5:24
  • You have to format the pendrive to run Ubuntu on a running OS. If you have already done that, you can boot the USB from your BIOS. If not, you'll have to go on another machine and format the pendrive with Gnome-Disks or the like with the ISO image. – RoundSauce Jun 18 '17 at 5:26
0

It is impossible to auto recover from this state. One thing you can do is -

boot from cdrom/usb and change permissions by hand ?

which is nearly impossible due to large volume of files.

So boot from usb/cdrom, backup your data (important files not whole partition as its access permissions to file system objects is also changed to 777) to another disk. Reinstall OS and restore the backup file.