On a fresh install of Ubuntu 17.04 I have problems with the screen flickering, going black for extended periods of time (~10 seconds) as well as "hot pixels" on the home screen and in some applications. The system is an Intel Skylake integrated graphics (HD 510) with no other graphics card that could be interfering.

The problem goes away if I either reduce the resolution (to 1080i or lower) or the refresh rate (from 60Hz to 30Hz).

Before the install, I was on Lubuntu 15.10 with no such problems.

From what I've been able to find out, it seems to be a kernel issue: I can break the working 15.10 install (kernel 4.2) by upgrading to kernel 4.4. And I can also almost fix the 17.04 install (kernel 4.10) by downgrading the kernel to 4.3 (almost in that the flickering goes down significantly without disappearing completely). Oddly enough, it seems that the higher the kernel version is, the worse the effect becomes.

Does anybody else have this problem?

Update: Having tried out (live usb) the new Ubuntu 17.10 this morning with high hopes, I have noticed something interesting: When I first tried it, it appeared to be okay. Now, after a couple of hours of tinkering with it, the issue is back as bad as ever. This would ordinarily make me think the problem might be heat-related, except the same machine runs happily and without problems for hours on end with the old Lubuntu 15.10. Very bizarre.

Summary of things I have (unsuccessfully) tried so far:

  • creating config script for the X server as suggested, among others, on the Arch wiki. This seems to be the go to advice for this sort of problem, but unfortunately it hasn't helped me.

    Section "Device"
        Identifier "Intel Graphics"
        Driver "intel"
        Option "AccelMethod" "sna"
        Option "TearFree" "true"
        Option "DRI" "3"

    I also tried this with AccelMethod uxa and it didn't help.

  • Enabling the intel microcode proprietary driver

  • nomodeset and i915.modeset=0 kernel parameters. This just limits my resolution to 1024x768 (or maybe it was 1280x1024, but either one isn't satisfactory)
  • i915.preliminary_hw_support=1, i915.enable_rc6=0, i915.enable_psr=0 kernel parameters
  • acpi=off kernel parameter
  • Upgrading drivers through the Intel graphics update tool as well as from this website (latest versions at the time of this writing: GuC - Ver 6.1, DMC - Ver 1.26, HuC - Ver 1.07)
  • Upgrading kernel to 4.11 and 4.12rc5, which has only seemed to make matters worse
  • apt-get purge xserver-xorg-video-intel, which hasn't helped, as well as a reinstall (suggested here)
  • Installing intel-vaapi-driver (from launchpad)
  • Different distros (Lubuntu 16.04.2, Lubuntu 17.04, Ubuntu 17.04, Fedora 25), they all have the same problem. Update: So does the recently released Lubuntu 17.10 (kernel 4.13.0-16)
  • Increasing the initially allocated memory to 1024MB in the BIOS
  • Enabling CSM in the BIOS
  • Setting the intel_iommu kernel parameter to off or igfx_off
  • Running stock Ubuntu 17.10. I thought maybe it was an X11 issue, and using Wayland might work. It didn't, although the exact symptoms changed slightly
  • Replacing the i915.ko file in the kernel's drivers directory with the working one from the 15.10 install. Somewhat surprisingly, this does not work. I had been halfway sure it would.
  • Does this happen with any screen? Do you have more than one type of connecting the screen? Do you know if this was happening with the previous OS? – Juan Antonio Jun 20 '17 at 16:31
  • 1
    Unfortunately I don't have any other screens to try with. But if I hook that same screen up to other computers there's no problem so I doubt it's an issue with the screen. On the previous install (lubuntu 15.10) everything was fine. – BadIdeaException Jun 20 '17 at 16:34
  • I am pretty sure I have the same thing here, on my T410s. I'd be most happy for updates, solutions, and willing to help out. I have the same: reducing resolution of the external monitor respectively frame rate improve things. Unfortunately, the screen settings seem to not be saved across reboots. Before, on 14.04, everything was fine. – udippel Aug 18 '17 at 8:05
  • You could find my other post on this close by. I happen to have two T410s, and one works perfectly (like in 14.04), while the other doesn't. I checked and checked for the difference: one is a 2904, the other a 2924. Everything else is identical. The 2904 doesn't work, and a major difference in dmesg is the iommu, failing. I searched for this and came across iommu=igfx_off. Have you tried this, too? – udippel Aug 18 '17 at 18:02
  • Actually no, I hadn't. I'll give it a try later today and let you know if it helped. – BadIdeaException Aug 19 '17 at 9:14

Its happened with me too on Intel graphics.. Some times these are the bugs also sometimes screen detection sensor does it is lided or unlided. It can be dust or something etc in your device.

I would suggest you to clean or check your device clearly after it then come towards removing of bugs.


I had a similar issue with Ubuntu 17.04 in my dual-booted HP-Pavilion laptop. Another thing I noticed was that the problems did not exist while running Windows.

This however stopped after I took steps to increase the airflow by playing around with fancontol. Alternatively I suggest opening your PC to clean and maintain the cooling fan.

I however do not face any such problems with Ubuntu 18.04.

Not the answer you're looking for? Browse other questions tagged or ask your own question.