Unfortunately I have a Xerox Workcentre 3025_NI multifunction printer and after installing the official driver on my Ubuntu Gnome 17.04 the scanner does not work, only the printer. Under 16.04 the printer and the scanner also work. I don't understand why.

Official driver here.

  • so you downloaded Xerox_WorkCentre_3025_Linux-Driver.tar.gz and its install script covers both scanner and printer? cd Downloads and tar -xzvf Xerox_WorkCentre_3025_Linux-Driver.tar.gz and cd uld and ./install.sh would be the needed lines
    – pdc
    Commented Jun 21, 2017 at 8:01
  • Yes, "install.sh" script install both scanner and printer. !Screenshot
    – Joe Member
    Commented Jun 21, 2017 at 9:04
  • 1
    I see in the file xerox_mfp.conf that lives inside /etc/sane.d ...... that there are entries for some of the Xerox WorkCentre devices; but not for the 3025 that you have; could you tell us what lsusb gives please for your Xerox; when it is plugged in and turned on; I am wondering whether adding an entry for it might help;
    – pdc
    Commented Jun 22, 2017 at 2:51
  • 1
    so you if install the text editor that is called gedit with the command sudo apt install gedit and then open the file xerox_mfp.conf with the command gksudo gedit /etc/sane.d/xerox_mfp.conf and scroll to the bottom of the file and edit one of the WorkCentre entries; so it now says #Xerox WorkCentre 3025 on the top line and usb 0x0924 0x42da on the line below; SAVE: CLOSE; reboot; I wonder if that helps at all
    – pdc
    Commented Jun 22, 2017 at 20:19
  • 1
    if you add your scanner to the libsane.rules file with gksudo gedit /lib/udev/rules.d/60-libsane.rules and scroll down as you did before to one of the WorkCentre entries and add ATTRS{idVendor}=="0924", ATTRS{idProduct}=="42da",in the right place .. any joy after a reboot?
    – pdc
    Commented Jun 24, 2017 at 20:48

5 Answers 5


I found an answer here.

I run the following two commands:

a) sudo ln -sfr /usr/lib/sane/* /usr/lib/x86_64-linux-gnu/sane

b) sudo adduser $USER lp

Then, I updated the file /etc/sane.d/xerox_mfp.conf using sudo vi /etc/sane.d/xerox_mfp.conf by adding the follwong two lines:

#Xerox WorkCentre 3025
usb 0x0924 0x42da

I saved and closed the file. And finally, reboot.

It worked fine.

  • 2
    This was for ubuntu 18.04 LTS.
    – Oualid
    Commented Aug 4, 2018 at 7:08
  • 1
    This worked for me but i did not ran sudo adduser $USER lp . My problem : ubuntu-mate.community/t/… Commented Feb 9, 2019 at 22:35
  • 1
    Does this method work for Ubuntu 20.04 LTS?
    – Arn
    Commented Feb 22, 2021 at 11:36
  • 1
    to Arn yes. I upgraded from 18.04 to 20.04 and still working !
    – Oualid
    Commented Feb 22, 2021 at 20:25
  • Worked on Ubuntu 22.04 lts !
    – MrXQ
    Commented Mar 27 at 13:11

I don't know about 17.04. But in 16.04 Xerox driver does not work. Since it is rebranded Samsung M2070, you can use samsung driver (V1.00.37_00.99) http://www.samsung.com/us/support/owners/product/wireless-mono-multifunction-printer-xpress-m2070

Printing works out of the box. Scanner discovery over network does not work. But workarround like simple-scan "smfp:net;PRINTER_IP_ADDRESS" does the trick.

EDIT: And just got scanner autodiscovery working by allowing port 22161 in firewall sudo ufw allow from to port 22161 Of course replace by your network range.


It is better to install Samsung drivers from the following page as they are deb packaged and automatically adds your device with udev: The Samsung Unified Linux Driver Repository


This might be a solution for you: https://www.hamrick.com/vuescan/xerox_workcentre_3025.html#technical-information They seem to be a boutique software company offering scanner solutions for Linux, MacOS, and Windows. I had a similar problem looking for a Linux solution for my Xerox Documate 510. I have not tried it yet but it appears to be the best alternative.


The solution given on the Xerox Forum worked for me for WorkCentre 3225 on 20.04. Try it. It may work for you too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .