I'm trying to install Lubuntu on a Asus Eee PC 1500HA of a friend of mine. It was running lubuntu already, but now I wanted to reinstall it with encryption. First I got the problem of the "swap", then of "lvm" and now, after I THOUGHT I installed it correctly, I got:

BusyBox v1.22.1 built-in shell (ash) Enter 'help' for a list of built-in commands


I tried to follow instructions here: How can I debug why Ubuntu boots to BusyBox?, but it didn't work... I tried some commands:

$ sudo blkid | grep swap
/dev/zram0: UUID="672ff5a1-9dd7-4b6d-b81c-5b80bf47810a" TYPE="swap"
/dev/zram1: UUID="a9af25d4-f007-4f1b-bdc8-cc2715ba3843" TYPE="swap"

$ sudo dumpe2fs /dev/sda2 | grep superblock
dumpe2fs 1.43.4 (31-Jan-2017)
dumpe2fs: Attempt to read block from filesystem resulted in short read while trying to open /dev/sda2
Couldn't find valid filesystem superblock

$ sudo blkid
/dev/sda1: UUID="cfe7e23c-2b60-408b-8181-ef36a68c75bb" TYPE="ext4" PARTUUID="f50e06aa-01"
/dev/loop0: TYPE="squashfs"
/dev/sda5: UUID="9f6412d3-4a57-4007-8c7b-91cbceb95016" TYPE="crypto_LUKS" PARTUUID="f50e06aa-05"
/dev/sdb1: UUID="2017-04-12-03-29-44-00" LABEL="Lubuntu 17.04 i386" TYPE="iso9660" PARTUUID="67a62368-01"
/dev/zram0: UUID="672ff5a1-9dd7-4b6d-b81c-5b80bf47810a" TYPE="swap"
/dev/zram1: UUID="a9af25d4-f007-4f1b-bdc8-cc2715ba3843" TYPE="swap"

$ cat /etc/fstab
aufs / aufs rw 0 0
tmpfs /tmp tmpfs nosuid,nodev 0 0

I don't understand these outputs as I don't know much about partitioning. How can I get my installation to boot?

  • Can you add the output of cat /etc/crypttab and lsblk to your question? Also, are you sure that is all that is in /etc/fstab? There should definitely be more than that.
    – b_laoshi
    Jun 20, 2017 at 1:40
  • Everything went fine with Xubuntu. My friend is happy and came to pick up. Thanks so much for the help also to you, b_laoshi.
    – Gino
    Jun 20, 2017 at 13:48

1 Answer 1


The Lubuntu Alternate Installer

It might work better, if you install from the Lubuntu alternate iso file. Otherwise there might be problems caused by zram, that is used when running live from a desktop iso file.

See the following link, that was made as instructions for testing iso files before release, but it is useful also in this case,

Alternate Install (Unencrypted home) in Lubuntu Alternate i386

These instructions are intended to install a Lubuntu system with encrypted disk (LVM with encryption).

  • It didn't work. The installation doesn't even start because of kernel. I'm right now trying installing xubuntu. I'll keep update.
    – Gino
    Jun 20, 2017 at 12:42
  • Xubuntu is not affected by problems with zram. (zram is used in the live session of Lubuntu to make it work with a very small amount of RAM). I don't understand why or how the Lubuntu alternate installer fails. Was there any output at all? Some warning or error output? Maybe it would help with some boot option. Anyway I'm looking forward to your results with Xubuntu. Good luck :-)
    – sudodus
    Jun 20, 2017 at 12:49
  • Everything went fine with Xubuntu. My friend is happy and came to pick up. Thank you so much fo the help.
    – Gino
    Jun 20, 2017 at 13:47
  • Congratulations @Gino! I'm glad that it worked with Xubuntu, and thanks for sharing your solution :-)
    – sudodus
    Jun 20, 2017 at 13:50

Not the answer you're looking for? Browse other questions tagged .