1

So I'm trying to install an ubuntu 64-bit virtual machine using virtualbox on my 64-bit windows 10 installation.

I've tried to get this installed about four times now in the past couple hours, and it has failed in various ways literally every single time, so I could really use some assistance.

My most recent failure has driven me into a state of almost incapacitating frustration, so let me break down exactly what I did:

  • In Virtualbox, create a new virtual machine, specified as an Ubuntu 17.04x64. I gave it 2048mb of RAM and 30gb of fixed storage.

  • Once the machine was created, I allowed the machine 4 cores, 128mb of video memory, and enabled 3D acceleration. All other settings were left at default.

  • I then loaded the Ubuntux64 iso into the Ubuntu VMs virtual drive in virtualbox, and started the VM.

  • I then proceeded with the linux installation as normal, telling it to install updates while installing.

  • Once the machine was up, I wanted to install guest additions. I don't really know why, hoping that they make the VM perform better I guess? I don't know really.

  • First, in terminal, I ran "sudo apt update" and "sudo apt upgrade," then rebooted the machine.

  • Once the machine was rebooted, I selected "Devices" then "Insert Guest Additions CD" (or whatever), and let autorun install (presumably) the guest additions.

  • I then shut down the machine.

Okay, so now I'm stuck in a login loop. The machine gets to the login screen, but when I type my password in, the screen flickers, turns black, and then returns me to the login.

Can anyone tell me what the hell is going on? What have I done wrong? Does anyone know of any way of fixing this at all?

Thank you. Please let me know if you'd like more details or to have anything clarified.

  • How many CPU cores does your host machine have? Allocating 4 cores to the guest is excessive. 2 should be fine. At the login prompt, hit control-alt-f1 and login to the text terminal. Show me the output of ls -al .*thority and pwd. – heynnema Jun 20 '17 at 1:26
  • Please also post potential errors as seen in ` /var/log/vboxadd-install.log`. – Takkat Jun 20 '17 at 7:56
  • @heynnema My CPU has 6 cores, so like 12 with...hyperthreading or whatever. I'll get the results of those terminal commands at some point, for the time being I've resorted to using an older VM I made running Ubuntu 16.04 or 16.10 (can't remember which it is exactly). Not having any problems with it other than subpar performance, but I feel like that's pretty typical with virtualbox. – GeneralPancake Jun 21 '17 at 17:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.