4

Exim4 has an option disable_ipv6=true. As great in many ways as Debian/Ubuntu's split configuration files for Exim4 may be, it makes it difficult sometimes to know where to put configuration options.

Where do I add the line disable_ipv6=true?

3

I think you can check and find file config /etc/exim4/update-exim4.conf. You can add option disable_ipv6=true and restart exim with command service exim4 restart.

After you added option you can check and netstat listening on port 25 against the IPv6 address as: netstat -tulpn | grep :25. If port 25 have listening in IPv6 maybe you can change dc_local_interfaces='127.0.0.1 ; ::1' --> dc_local_interfaces='127.0.0.1'.

Finally, finally, I noticed that there is a configuration template file/etc/exim4/exim4.conf.template. Curiously, I’ve added disable_ipv6=true directive over there, restarted exim and maybe it started working.

I hope you will find this article useful, and save some time when you run into similar problem with exim.

1
### main/02_exim4-config_options
#################################

disable_ipv6
dns_ipv4_lookup='*'
#dns_ipv4_lookup = *gmail.com

I plan to get a little more fine-grained, presently I'm belt and braces sure not to need the qualifications to speak SMTP over IPv6 to Google Mail. Indeed that seems a little antethical to the ethos of the sphere.

  • 1
    I don't understand what you mean. What is this snippet? Why does it answer the question? – Ingo Mar 4 '18 at 10:41
1

If your only need is to get around Google's IPv6 reverse DNS (PTR record) policies, add the following to main/02_exim4-config_options.

dns_ipv4_lookup = *google.com : *gmail.com

This will effectively disable IPv6 (address lookups) to any message going to Gmail without disabling IPv6 entirely.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.