0

I have a strange problem. I have a laptop and a PC connected to the same wifi, running Ubtunu 16.04 and the latency is very high, sometimes it even stays around 300 ms, but it also has a high jitter. The strange part is that the latency is less than a millisecond if I run Windows 10 on that PC (laptop still running Ubuntu).

I tried to run a trick I googled,

sudo iwconfig wlp3s0 power off

but it did not help (the wifi device's name is really wlp3s0). The hardware used is (according to lspci) Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter (rev 32).

If I use a RJ45 wire to connect the two machines, it runs without issues. The latency to servers outside the local network is far from being that bad.

It makes file transfer really annoying and synergy unusable.

Any idea what might be causing this?

EDIT: More info: What I from iwlist scanning:

Cell 01 - Address: 90:5C:44:A0:F7:B1
                Channel:112
                Frequency:5.56 GHz (Channel 112)
                Quality=56/70  Signal level=-54 dBm  
                Encryption key:on
                ESSID:"DugiNet Premium"
                Bit Rates:6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                          36 Mb/s; 48 Mb/s; 54 Mb/s
                Mode:Master
                Extra:tsf=0000030ca45f5bbb
                Extra: Last beacon: 33488ms ago
18
  • Are you using 2.4ghz or 5ghz? First, make sure that you're using WPA2-AES. Then, if you're using 2.4ghz, switch your wireless channel from auto, to 1 or 6 or 11, and see if that helps. Try each one. Report back.
    – heynnema
    Jun 19, 2017 at 14:46
  • I am getting that channel is 112, frequency 5.56 GHz. I am not sure if I am using WPA2-AES (it is some WPA2 for sure), but that is a setting of the router and the laptop's wireless is okay. I could not change the channel, it reports that SET failed, because the device was busy (using sudo iwconfig wlp3s0 channel 1).
    – Dugi
    Jun 19, 2017 at 15:12
  • No, I'm sorry. The changes that I suggest are in the router. If you're using 5ghz, try channel 40. Also, understand the 5ghz will not reach as far as 2.4ghz. Report back.
    – heynnema
    Jun 19, 2017 at 15:15
  • It works fine on Windows 10 on the PC or on the laptop. I thought this was a driver issue. I need to find the router's manual to connect to it, it will take some time.
    – Dugi
    Jun 19, 2017 at 15:18
  • Is Windows using the same freq/channel? Windows does things a little differently, so it's hard to compare. To get to the router, just go to the router's address in your web browser... typically http://192.168.0.1 or http://192.168.1.1.
    – heynnema
    Jun 19, 2017 at 15:21

1 Answer 1

1

From the comments...

The subject line indicates that two computers on the same network have high latency and can't run Synergy. This isn't exactly accurate, as the laptop was connecting to the 2.4ghz network, and the PC was connecting to the 5ghz network. Ping times between computers was ~300ms. Ping times from either the laptop or the PC to the router were fine. The PC could not be pinged when connected to the 5ghz network.

Once the laptop and the PC were both connected to the 2.4ghz network, ping times came down to 2-60ms, and Synergy worked fine. The PC could now be pinged. To continue testing in this configuration, the router needs to be changed from auto to either channel 1/6/11 and retested with each setting change. Use ping times to determine performance.

The 2.4ghz and 5ghz networks need to have different names.

For now, if the laptop can do 5ghz, then connect both computers to the same 2.4ghz or 5ghz network. Later testing with laptop/PC on different wireless networks is going to require tweeking the VLAN/BR0 settings in the router.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.