0

After building my application using vamp-plugins:

kokos@kokos-Latitude-E6230:~/repo/pitchtracker/pitchtracker$ ./vamp-simple-host -l

Following error occur:

./vamp-simple-host: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by ./vamp-simple-host)
./vamp-simple-host: /usr/lib/x86_64-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by ./vamp-simple-host)

I tried following:

sudo add-apt-repository ppa:ubuntu-toolchain-r/test

sudo apt-get update and also upgrade and dist-upgrade

export LD_LIBRARY_PATH=${prefix}/lib:$LD_LIBRARY_PATH

And this:

mv -vf libstdc++.so.6 libstdc++.so.6.old
ln -s /usr/lib/x86_64-linux-gnu/libstdc++.so.6 ./libstdc++.so.6

Caused a SERIOUS system error

Output of apt-cache policy libstdc++6:

libstdc++6:
  Zainstalowana: 7.1.0-5ubuntu2~14.04
  Kandydująca:   7.1.0-5ubuntu2~14.04
  Tabela wersji:
 *** 7.1.0-5ubuntu2~14.04 0
        100 /var/lib/dpkg/status
     4.8.4-2ubuntu1~14.04.3 0
        500 http://pl.archive.ubuntu.com/ubuntu/ trusty-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ trusty-security/main amd64 Packages
     4.8.2-19ubuntu1 0
        500 http://pl.archive.ubuntu.com/ubuntu/ trusty/main amd64 Packages

I've obtained vamp-plugins by compiling from source which I've downloaded from their official website:

./configure
make 
sudo make install
  • Please add the output of apt-cache policy libstdc++6. BTW how did you obtain and install the vamp plugin(s)? – steeldriver Jun 19 '17 at 11:51
  • @steeldriver I've added answer in the edit to my initial post. It worked on the other PC. – Kokos34 Jun 19 '17 at 17:48
  • Hmm.. if you have successfully upgraded to libstdc++6 version 7.1.0-5ubuntu2~14.04, you should have /usr/lib/x86_64-linux-gnu/libstdc++/libstdc++.so.6.0.23 which should provide GLIBCXX versions up to 3.4.23 (you can confirm with strings /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.23 | grep 'GLIBCXX_'). Do you still have a modified LD_LIBRARY_PATH? – steeldriver Jun 19 '17 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.