4

I am using Ubuntu 17.04 (budgie desktop), and I disabled the bluetooth service to prevent the bluetooth from being enabled with the computer startup. I used this command to disable it :

sudo systemctl disable bluetooth.service

And I used this command to confirm that it is disabled :

systemctl is-enabled bluetooth.service
> disabled

But sometimes, the bluetooth (and some other services) are starting with the computer even if they are disabled. Is it a bug ? or am I missing something here ?

3

Maybe some other service or socket needs them thus starts them at the point of need. You should mask the service if you don't want it to be started in any way (Automatically, manually or by any other service) :

sudo systemctl mask name.service
sudo systemctl stop name.service
sudo systemctl disable name.service

Masking a service points it to /dev/null so it's not going to be enabled/started anymore.

If you want to enable it again use:

sudo systemctl unmask name.service
sudo systemctl enable name.service

To find out which services are depends on a specific service you can use something like:

grep -Ri name.service /lib/systemd/system

e.g:

$ grep -Ri bluetooth.service /lib/systemd/system
./tlp.service:Wants=bluetooth.service NetworkManager.service

we can see in my Ubuntu tlp service needs bluetooth and NetworkManager.

A better option is to use:

$ systemctl list-dependencies bluetooth.service --reverse 

bluetooth.service
● └─tlp.service
  • Thanks, very useful informations. Is there a way to know which service is starting my disabled services (since they didn't start automatically). – Sidahmed Jun 19 '17 at 8:34
  • I've done another update, it might be helpful to notice ;) – Ravexina Jun 19 '17 at 9:21
  • This is epic, the second approach is even better. Thanks. – Sidahmed Jun 19 '17 at 9:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.