-1

When i trying to update i got this error. I am using Ubuntu 17.04.

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  apache2-bin
Suggested packages:
  apache2-doc apache2-suexec-pristine | apache2-suexec-custom
The following NEW packages will be installed:
  apache2-bin
0 upgraded, 1 newly installed, 0 to remove and 10 not upgraded.
2 not fully installed or removed.
Need to get 949 kB of archives.
After this operation, 3,781 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://archive.ubuntu.com/ubuntu zesty/main amd64 apache2-bin amd64 2.4.25-3ubuntu2 [949 kB]
Fetched 949 kB in 12s (76.5 kB/s)                                                    
(Reading database ... 212651 files and directories currently installed.)
Preparing to unpack .../apache2-bin_2.4.25-3ubuntu2_amd64.deb ...
Unpacking apache2-bin (2.4.25-3ubuntu2) ...
dpkg: error processing archive /var/cache/apt/archives/apache2-bin_2.4.25-3ubuntu2_amd64.deb (--unpack):
 trying to overwrite '/usr/lib/apache2/modules/httpd.exp', which is also in package apache2.2-bin 2.2.22-1ubuntu1.11
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/apache2-bin_2.4.25-3ubuntu2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
2
  • Exactly what command did you run ? I only see some output.
    – Soren A
    Jun 19, 2017 at 8:21
  • sudo apt --fix-broken install
    – Ranjit
    Jun 19, 2017 at 9:22

1 Answer 1

0

The error says that you are trying to install apache2-bin but it tries to overwrite a file belonging to installed package apache2.2-bin.

Apparently you can't have both apache2 and apache2.2 installed, since they use same filesystem namespace.

5
  • Still i am getting this error. dpkg-deb: error: subprocess paste was killed by signal (Broken pipe) Errors were encountered while processing: /var/cache/apt/archives/apache2-bin_2.4.25-3ubuntu2_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)
    – Ranjit
    Jun 19, 2017 at 9:18
  • You can't install apache2-bin when you already have apache2.2-bin installed !!
    – Soren A
    Jun 19, 2017 at 9:24
  • How can i remove that ? Or any other solution.
    – Ranjit
    Jun 19, 2017 at 9:27
  • Why do you want to install the apache2-bin package, when you already have apache2.2-bin ?
    – Soren A
    Jun 19, 2017 at 9:34
  • I am trying sudo apt-get remove apache2.2-bin I am getting this error. apache2-mpm-worker : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.11) but it is not going to be installed apache2.2-common : Depends: apache2.2-bin (= 2.2.22-1ubuntu1.11) but it is not going to be installed libapache2-mod-php7.0 : Depends: apache2-api-20120211 E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
    – Ranjit
    Jun 19, 2017 at 9:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .