In just the last few weeks I've been having huge problems with connecting to certain WIFI-networks on my Ubuntu 16.04 LTS.

I can connect to my home WIFI and certain other ones (as well as my phone's hotspot) but some other networks (including work) I never seem to be able to connect to. When I choose them from the list of available networks, the computer just tries to connect with it for 10-20 seconds and then says it was disconnected.

I asked Google for help with this but none of the solutions I tried (restarting Network manager and so on) worked, I still get the same error. This is my wireless-info file:

https://drive.google.com/file/d/0B-UyzfVp6kcPLW9VcHBJMmtKWms/view?usp=sharing

This is quickly becoming a huge issue for me as I need to be online in order to do my work.

How do I fix this? Thanks a lot for all help!

//Felix

up vote 1 down vote accepted

First, I suggest that you remove the incorrect Broadcom driver. As your device is an Intel, the driver is not helpful. From the terminal:

sudo apt-get purge bcmwl-kernel-source
sudo modprobe -r wl

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

If these changes do not help, please try:

sudo modprobe -r iwlwifi
sudo modprobe iwlwifi 11n_disable=8

If it helps, make it permanent:

sudo -i
echo "options iwlwifi 11n_disable=8"  >>  /etc/modprobe.d/iwlwifi.conf
exit

Is there any improvement? It may take a reboot.

  • I went through your amazing answer but it still doesn't work :( When I try the first modeprobe-command, this is the answer I get: modprobe: FATAL: Module wl not found. When I get my country code I get 00, but when I try to change it, on both methods, I still get 00 as the country? Also, I can't edit the IPv6 settings as they are all greyed out when I try to edit my work wifi (which I have never been able to connect to). Also, your last few commands didn't make anything different, not that I noticed? Anyway, thanks for your help, but how do I continue from here on out? – Felix Eder Jun 20 '17 at 7:58
  • 1
    I managed to connect to my work WI-FI by removing it from my known networks and then re-adding it as a hidden network by typing in the name and password directly in the network manager. It's not fancy, but until I figure out why I can't connect properly, this is a good enough work around. – Felix Eder Jun 20 '17 at 11:16

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.