0

Running Xubuntu 17.04 on a little old acer aspire one.

Suspend just doesn't seem to work very well on this computer. Suspending by closing the lid has never worked (even the screen remains on), and rather than troubleshoot it I just made a keybinding that suspends on Super-S. That worked fine for a while but in the last couple of days this new problem has appeared:

Periodically (about every third or fourth suspend) it now shows a black screen for a few seconds and then just puts me on the login screen. It doesn't seem to have anything to do with my keybinding as it also does this when suspending from the whisker menu. Also, it doesn't matter if suspending or shutting down, the result is the same. The only thing I can do is hard shut down the computer at that point.

I checked dmesg but it only showed messages since the last time I had force shut down, so no help there. Next time it happens I'll try to grab the dmesg output and post it here but I hoped maybe someone recognized the problem, it's annoying as when this happens I'm always trying to put my computer away and often cannot sit and troubleshoot it.

I think it might be related to this: laptop fails to suspend or hibernate but it at least does not appear to be the same module causing the issue as I do not have that module listed as enabled for wakeup. Here's my output on that:

sarai@ninjacer:~$ cat /proc/acpi/wakeup
Device  S-state   Status   Sysfs node
USB0      S3    *enabled   pci:0000:00:1d.0
USB1      S3    *enabled   pci:0000:00:1d.1
USB2      S3    *enabled   pci:0000:00:1d.2
USB3      S3    *enabled   pci:0000:00:1d.3
USB7      S3    *enabled   pci:0000:00:1d.7
RP01      S4    *disabled  pci:0000:00:1c.0
PXSX      S4    *enabled   pci:0000:01:00.0
PXSX      S4    *disabled  pci:0000:02:00.0
PXSX      S4    *disabled  pci:0000:03:00.0
    *disabled  platform:rtsx_pci_sdmmc.0
    *disabled  platform:rtsx_pci_ms.0
PXSX      S4    *disabled
  • I think the older hardware is not suitable for suspending and/or the laptop is low on memory. – user680858 Jun 19 '17 at 6:12
0

It's been over a full day since this reoccured. I wonder if something got fixed in an update? It has been suspending properly, whereas before it would happen several times a day. I guess this is resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.