0

I installed Ubuntu 17.04 on a Toshiba Satellite L500 and I can't connect to the internet even though the computer connects the network via wifi.

I tried changing 'method' to 'ignore' on the IPv6 definitions tab in the edit settings dialogue of the wifi network I'm using; after rebooting it worked but now it's not working again. I also uncommented line precedence ::ffff:0:0/96 100 in /etc/gai.conf but it didn't worked. I also tried to run apt-get update but it failed with W: Some index files failed to download. They have been ignored, or old ones used instead; oddly apt-get upgrade worked. Can you please help me?

EDIT 3

It's very strange, the internet connection keeps failing for some minutes once in a while... Why does that happen?!?

EDIT 2

Apparently the problem was the server I was using. I changed it and now it works.

EDIT 1

Oddly enough the internet is now working again; however apt-get update isn't.

1.

$ ping www.google.com

--- www.google.com ping statistics ---
135 packets transmitted, 131 received, 2% packet loss, time 134259ms
rtt min/avg/max/mdev = 26.607/32.161/376.156/30.244 ms

2.

$ nslookup www.google.com
Server:     127.0.0.53
Address:    127.0.0.53#53

Non-authoritative answer:
Name:   www.google.com
Address: 216.58.210.132

3.

$ dig www.google.com

; <<>> DiG 9.10.3-P4-Ubuntu <<>> www.google.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 25857
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;www.google.com.            IN  A

;; ANSWER SECTION:
www.google.com.     62  IN  A   216.58.210.132

;; Query time: 0 msec
;; SERVER: 127.0.0.53#53(127.0.0.53)
;; WHEN: Mon Jun 19 03:04:46 WEST 2017
;; MSG SIZE  rcvd: 59
4
  • login to your wireless router and verify it's settings (I assume it's your wireless router). The problem could be either at the router (likely), or getting the router + computer to agree (less likely, but maybe check if both router+computer allow both ipv4 and ipv6 traffic). Obviously, if you have another computer / device attached to the same wifi router that does have access to the internet, then this probably isn't the problem. Also, run some commands like "ping www.google.com", nslookup, dig, etc, to see if it's DNS or all traffic.
    – michael
    Jun 19, 2017 at 1:54
  • I don't have access to the router but there's another machine connecting to this network with no problems.
    – JFerreira
    Jun 19, 2017 at 2:12
  • If you cannot check the router settings yourself, then get in touch with someone who can. It is possible your machine's MAC address has been disallowed certain protocols. It could also be something simple as that the router has reached its maximum number of devices.
    – user680858
    Jun 19, 2017 at 6:40
  • ok, it could be this issue (ubuntu mac address randomly being changed), since you can intermittently connect. Try the steps here to disable random mac address assignment & see if you can stay connected: askubuntu.com/questions/904844/…
    – michael
    Jun 20, 2017 at 8:31

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.