12

Good day,

I have tried multiple times, USB used Rufus to make bootable disk, tried others in the past.

After boot choose try or install Ubuntu, get 2 lines:

0.3055641 platform wdat_wdt: failed to claim resource: 1
0.3055781 ACPI: watchdog: Device creation failed: -16

Tried both Ubuntu and install Ubuntu, same errors. Then system just hangs.

Been at it 2 days now.

Any help appreciated.

2
  • It is likely due to the USB device. Instead of trying to figure out why, maybe you can try another USB disk. In addition, you can tell rufus to use the 'dd' mode instead of 'iso' mode, the former way is more robust to boot.
    – funicorn
    Dec 31, 2017 at 3:17
  • @jbruced can it be due to bad sectors in your hard disk? Jun 1, 2020 at 3:33

2 Answers 2

1

The error:

ACPI: watchdog: Device creation failed: -16

means that the system failed to create the watchdog device because some of the resources were already reserved (-EBUSY). see: Linux git commit

platform wdat_wdt: failed to claim resource: 1

Although based on the the resource number, there is not enough information to figure out which resource range failed to claim. There is a Linux patch which can print the resource range if device failed to claim, based on which /proc/iomem or ioports should tell who already claimed this resource, and whether it's a driver bug or incorrect resource assignment which is running into this conflict, so it can be diagnosed further.


Some people suggest that it can be caused by some problem with your bootable disk. So you can try to disable USB 3.0 or try a different USB device instead (USB 2.0 instead). You may also to create the bootable USB again, but using different software, e.g. UNetbootin. Another workaround is just to burn disk a DVD instead and try again. see: USBlive fails to boot


Other things you can try is to enable or disable ACPI support in BIOS. Some other people suggest that it could be a video card issue.


To find more about the issue, try disabling quiet mode which may show more boot messages. So when you're on the grub menu while booting, press Tab or e , hit X to edit, then delete quiet and add nomodesetsee: linux.com (this instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded).see: ubuntuforums

2
  • 1
    Thank you for the responce, set laptop to usb 2.0., tried Unetbootin, Rufus and Universal USB Installer, rufus no boot, the others show same errors as listed above. DVD not an option.
    – jbruced
    Jul 15, 2017 at 14:25
  • @jbruced Expanded answer for extra suggestions.
    – kenorb
    Jul 15, 2017 at 20:12
1

I have just managed to solve this

Determine what is the Device creation failed: number

if it is -16:

  1. 0.3055781 ACPI: watchdog: Device creation failed: -16

It is the TPM (Trusted Platform Module), feature which implements cryptographic keys storage, used to improve security for technologies such as bitlocker.

Action: Disable this and error should go away or change to another number)

if the number is 4

  1. 0.3055781 ACPI: watchdog: Device creation failed: 4

Action: Change the USB mode in the BIOS from 3.0 to 2.0 or viceversa

If none of the above work follow these steps:

  • Check your .ISO file integrity with MD5 or SHA256 (this is boring but saves you lots of time)
  • Create the bootable USB using unetbootin - https://unetbootin.github.io/ making sure you disable (set to 0) the local file storage for any Linux distro that is not UBUNTU

UNetBootIn options In my case it seems that the .ISO file was corrupt, I downloaded it again in another computer, checked the integrity and follow the steps above and I have now a booting USB that will allow me to fix/reinstall my laptop

If problem continues, format your USB with bad block check and try again

Not the answer you're looking for? Browse other questions tagged or ask your own question.